Bug 13679 - New class can be created under projects folder
New class can be created under projects folder
Status: CLOSED DUPLICATE of bug 13677
Product: projects
Classification: Unclassified
Component: Generic Projects UI
3.x
Sun Solaris
: P1 (vote)
: 3.x
Assigned To: issues@projects
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-18 08:55 UTC by Martin Balin
Modified: 2003-07-01 14:16 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Balin 2001-07-18 08:55:31 UTC
[JDK 1.3.1 200107170100]

1. Create new project - ProjectY under some directory structure e.g. "com.cocom"
2. Invokde New -> Class on newly created project node ProjectY
3. Enter name "ClassX" and select packages under Filesystems:
com.cocom.ProjectY. Class can be created under project folder!
4. Press Finish button.

Class "ClassX" is created and its package statement is following "package
com.cocom.ProjectY" class itself is displayed twice in Workplace tab. Once as
normal Java object and second as shadow.

If we are using directory for projects storage then we have to preserve users
from creation of regular files under them. It is confusing.
Comment 1 Jan Pokorsky 2001-07-18 09:02:52 UTC
duplicate

*** This issue has been marked as a duplicate of 13677 ***
Comment 2 Jaromir Uhrik 2001-07-18 16:03:14 UTC
Verified - It is really a duplicate
Comment 3 Quality Engineering 2003-07-01 14:16:58 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo