Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 13677 - New class can be created under projects folder
New class can be created under projects folder
Status: VERIFIED INVALID
Product: projects
Classification: Unclassified
Component: Generic Projects UI
3.x
Sun Solaris
: P3 (vote)
: 3.x
Assigned To: Vitezslav Stejskal
issues@projects
:
: 13679 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-18 08:03 UTC by Martin Balin
Modified: 2005-07-12 09:40 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Balin 2001-07-18 08:03:25 UTC
[JDK 1.3.1 200107170100]

1. Create new project - ProjectY under some directory structure e.g. "com.cocom"
2. Invokde New -> Class on newly created project node ProjectY
3. Enter name "ClassX" and select packages under Filesystems:
com.cocom.ProjectY. Class can be created under project folder!
4. Press Finish button.

Class "ClassX" is created and its package statement is following "package
com.cocom.ProjectY" class itself is displayed twice in Workplace tab. Once as
normal Java object and second as shadow.

If we are using directory for projects storage then we have to preserve users
from creation of regular files under them. It is confusing.
Comment 1 Jan Pokorsky 2001-07-18 09:02:51 UTC
*** Issue 13679 has been marked as a duplicate of this issue. ***
Comment 2 Pavel Buzek 2001-07-18 12:46:58 UTC
I agree that it is cofusing but AFAIK it is pretty harmless (no data loss, easy work around). I do not 
agree that this is a P1 bug and I am lowering priority to P3. 
I you disagree, please add more arguments.
Comment 3 Vitezslav Stejskal 2001-08-03 13:46:03 UTC
taking this issue
Comment 4 Vitezslav Stejskal 2001-08-16 18:22:10 UTC
Related to Nb 4.0 projects implementation, changing milstone to 4.0.
Comment 5 Pavel Buzek 2001-10-22 17:34:14 UTC
does not appear in 3.3, version -> 4.0
Comment 6 Pavel Buzek 2001-11-28 10:50:11 UTC
target milestone -> 4.0
Comment 7 Pavel Buzek 2002-01-31 09:49:01 UTC
bug in 3.3 exerimental code which will be rewritten for 4.0 projects
Comment 8 Marian Mirilovic 2005-07-12 09:40:40 UTC
closed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo