Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 131710 - The Undo and Redo actions missing in the keymap customizer
The Undo and Redo actions missing in the keymap customizer
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Key bindings
6.x
All All
: P3 with 1 vote (vote)
: 6.x
Assigned To: issues@editor
issues@editor
61fixes3-fixed
:
: 134738 139487 142411 (view as bug list)
Depends on: 133618
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-01 12:50 UTC by Jiri Prox
Modified: 2008-09-04 13:22 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Prox 2008-04-01 12:50:15 UTC
Product Version: NetBeans IDE Dev (Build 200803311211)
Java: 1.6.0_06; Java HotSpot(TM) Client VM 10.0-b22
System: Linux version 2.6.22-14-generic running on i386; UTF-8; en_US (nb)

The Undo action is not present in the Options-> Keymap so the user cannot customize the shortcut.
Also when adding Ctrl-Z shortcut for some action, there is no warning that the shortcut is already set. After
confirming, the Ctrl-Z still calls Undo and not the newly assigned action.

(this may by related to issue 118038)
Comment 1 Vitezslav Stejskal 2008-04-02 10:43:57 UTC
Reproducible. Both Redo/Undo are missing for some reason. Their shortcuts work though, so it's probably unrelated to
#118038.
Comment 2 Jiri Prox 2008-05-12 10:57:40 UTC
*** Issue 134738 has been marked as a duplicate of this issue. ***
Comment 3 Karthikeyan Rajeswaran 2008-06-23 20:22:33 UTC
Also discussed at: http://www.nabble.com/Re%3A-BrainFart-or-Something-has-changed.-p17187295.html
Comment 4 Jiri Prox 2008-07-10 09:35:08 UTC
*** Issue 139487 has been marked as a duplicate of this issue. ***
Comment 5 Vitezslav Stejskal 2008-07-30 16:09:51 UTC
Fixed with issue #133618.
Comment 6 Jiri Prox 2008-07-31 15:38:41 UTC
*** Issue 142411 has been marked as a duplicate of this issue. ***
Comment 7 athompson 2008-07-31 20:54:39 UTC
has this also been fixed for the other actions that don't show up in the keymap, such as 'toggle comment'?
Comment 8 Jiri Prox 2008-08-01 07:41:50 UTC
yes, all actions should be visible in keymap now - toggle comment is located in category Other
Comment 9 rbalada 2008-08-04 21:58:42 UTC
Jirko,

please consider adding 61fixes3-candidate keyword to status whiteboard.
Comment 10 Jiri Prox 2008-08-05 07:21:21 UTC
verified
Comment 11 Jiri Prox 2008-08-05 07:24:20 UTC
adding nomination for patch3, it's fixed by commit which is already included in patch3, so the status whiteboard will
reflect the current status of the issue
Comment 12 rbalada 2008-08-06 11:18:23 UTC
Marking with status white board keywrod 61fixes3-fixed. Real fix happened in issue 133618. Status whiteboard keyword
added for patch verification.
Comment 13 Jiri Prox 2008-08-21 08:40:51 UTC
verified in patch


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo