Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 133618 - Some keybindings lost when duplicating keymap profile
Some keybindings lost when duplicating keymap profile
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Key bindings
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Vitezslav Stejskal
issues@editor
61fixes3-fixed
:
: 133307 134305 135952 140223 (view as bug list)
Depends on:
Blocks: 131710 133170
  Show dependency treegraph
 
Reported: 2008-04-22 10:44 UTC by Jiri Prox
Modified: 2008-09-04 13:20 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Prox 2008-04-22 10:44:51 UTC
Product Version: NetBeans IDE 6.1 (Build 200804211638)
Java: 1.6.0_10-beta; Java HotSpot(TM) Client VM 11.0-b11
System: Linux version 2.6.22-14-generic running on i386; UTF-8; en_US (nb)
Userdir: /home/jp159440/.netbeans/6.1

Some keybindings  are lost when duplicating keymap profiles. I have seen this on copy/paste, undo, or delete action, but
unfortunatelyI cannot find the pattern when this happens.

The IDE was started with fresh userdir
Comment 1 Vitezslav Stejskal 2008-04-23 09:33:34 UTC
So the steps are:

1. run the IDE with a fresh userdir
2. duplicate 'Netbeans' keybinding profile, make it active and confirm the Tools-Options dialog
3. open a java file for example and try ctrl+C, ctrl+V, DEL shortcuts

The shortcuts won't work, right? Does restarting the IDE help?
Comment 2 Jiri Prox 2008-04-23 09:59:51 UTC
Yes, the steps are correct.  
The shortcut does not work and is not assigned to related action in keymap 

Restart does not help.
Comment 3 Vitezslav Stejskal 2008-05-04 18:23:09 UTC
*** Issue 134305 has been marked as a duplicate of this issue. ***
Comment 4 Vitezslav Stejskal 2008-05-04 18:23:44 UTC
*** Issue 133307 has been marked as a duplicate of this issue. ***
Comment 5 Vitezslav Stejskal 2008-05-04 18:25:01 UTC
Sounds serious. Please also look at issue #133170, which describes some other 'missing' shortcuts.
Comment 6 Jiri Prox 2008-05-28 07:55:14 UTC
*** Issue 135952 has been marked as a duplicate of this issue. ***
Comment 7 Jan Becicka 2008-07-14 12:23:41 UTC
*** Issue 138556 has been marked as a duplicate of this issue. ***
Comment 8 Vitezslav Stejskal 2008-07-14 17:55:34 UTC
Also see issue #138751.
Comment 9 Vitezslav Stejskal 2008-07-23 09:48:47 UTC
*** Issue 140223 has been marked as a duplicate of this issue. ***
Comment 10 Jan Becicka 2008-07-23 15:06:33 UTC
Maxi, please take a look at it. Thanks.
Comment 11 Jan Becicka 2008-07-29 14:56:12 UTC
Vito, please take a look at it. Thanks.
Comment 12 Vitezslav Stejskal 2008-07-30 16:08:55 UTC
http://hg.netbeans.org/main/rev/84779e36d109
Comment 13 Quality Engineering 2008-07-31 04:26:16 UTC
Integrated into 'main-golden', available in build *200807310201* on http://bits.netbeans.org/dev/nightly/
Changeset: http://hg.netbeans.org/main/rev/84779e36d109
User: Vita Stejskal <vstejskal@netbeans.org>
Log: #133618 (fixed): properly refresh the actions cache
Comment 14 rbalada 2008-08-04 15:53:40 UTC
Please note that NetBeans 6.1 Patch3 cut-off is going to happen on close of
business August 5th. If you would like to have bugfix for this issue as part of
NetBeans 6.1 Patch3, then this issue must have information about bugfix' trunk
changeset and it's status must be "VERIFIED".
Comment 15 Jiri Prox 2008-08-04 15:53:41 UTC
verified
Comment 16 rbalada 2008-08-04 21:48:09 UTC
I've transplanted the changeset http://hg.netbeans.org/main/rev/84779e36d109 into release61_fixes repository as
http://hg.netbeans.org/release61_fixes/rev/0b7e8a032018
Comment 17 Jiri Prox 2008-08-05 12:06:20 UTC
There are still problems with duplicating profile - sometimes it doesn't work


Product Version: NetBeans IDE Dev (Build 20080731042603)
Java: 1.6.0_10-rc; Java HotSpot(TM) Client VM 11.0-b13
System: Linux version 2.6.22-15-generic running on i386; UTF-8; en_US (nb)
Comment 18 Jiri Prox 2008-08-06 10:20:40 UTC
The behavior was improved by the fix, so we agreed that it's worthy to include it in the patch, although the issue is
not fixed completely. For the remaining part of this issue there is separate report created - issue 143018 
Comment 19 Jiri Prox 2008-08-06 10:23:13 UTC
v.
Comment 20 rbalada 2008-08-06 11:16:40 UTC
OK, I'll keep it in the NB 6.1 Patch 3 (in other words not going to backout the change).
Comment 21 Jiri Prox 2008-08-21 08:41:08 UTC
verified in patch


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo