Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 129249 - java.io.IOException: Server returned HTTP response code: 403 for URL:
java.io.IOException: Server returned HTTP response code: 403 for URL:
Status: RESOLVED FIXED
Product: ide
Classification: Unclassified
Component: Exceptions Reporter
6.x
All All
: P1 (vote)
: 6.x
Assigned To: jcatchpoole
logger-issues@ide
:
: 129252 129264 129333 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-05 10:02 UTC by Lukas Hasik
Modified: 2008-03-16 19:11 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
application.jar (2.02 KB, application/octet-stream)
2008-03-05 11:03 UTC, Jindrich Sedek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Hasik 2008-03-05 10:02:21 UTC
today (3/5) I receive IOE when using the Reprot Exception tool in NB

java.io.IOException: Server returned HTTP response code: 403 for URL:
http://testwww.netbeans.org/nonav/uigestures/error.html
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1170)
	at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:367)
	at javax.swing.JEditorPane.getStream(JEditorPane.java:689)
Caused: java.io.IOException: Server returned HTTP response code: 403 for URL:
http://testwww.netbeans.org/nonav/uigestures/error.html
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
	at sun.net.www.protocol.http.HttpURLConnection$6.run(HttpURLConnection.java:1223)
	at java.security.AccessController.doPrivileged(Native Method)
	at sun.net.www.protocol.http.HttpURLConnection.getChainedException(HttpURLConnection.java:1217)
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:906)
	at javax.swing.JEditorPane.getStream(JEditorPane.java:719)
	at javax.swing.JEditorPane.setPage(JEditorPane.java:406)
	at org.netbeans.modules.uihandler.Installer$SubmitInteractive.assignInternalURL(Installer.java:1238)
	at org.netbeans.modules.uihandler.Installer$Submit.doShow(Installer.java:845)
	at org.netbeans.modules.uihandler.Installer.doDisplaySummary(Installer.java:434)
	at org.netbeans.modules.uihandler.Installer.displaySummary(Installer.java:408)
	at org.netbeans.modules.uihandler.UIHandler.run(UIHandler.java:132)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:561)
[catch] at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:986)
Comment 1 Jaroslav Tulach 2008-03-05 10:29:43 UTC
Jack, can you help us, no Java program seems to be able to connect to netbeans.org, can collab fix it somehow?
Comment 2 Jindrich Sedek 2008-03-05 11:02:35 UTC
I'm attaching simple java application:
code:
       URL  postURL = new URL(args[0]);
       URLConnection conn = postURL.openConnection();
       InputStream stream = conn.getInputStream();
       BufferedReader reader = new BufferedReader(new InputStreamReader(stream));
       String str = reader.readLine();
       System.out.println(str);
       reader.close();
       stream.close();
usage:
java -jar application.jar http://www.netbeans.org
 -> result IOException
java -jar application.jar http://www.google.com
 ->first page line is printed

you can verify functionality using this simple app
Comment 3 Jindrich Sedek 2008-03-05 11:03:20 UTC
Created attachment 57795 [details]
application.jar
Comment 4 Jindrich Sedek 2008-03-05 11:42:58 UTC
*** Issue 129264 has been marked as a duplicate of this issue. ***
Comment 5 Jindrich Sedek 2008-03-05 15:15:54 UTC
let's show error message instead of throwing exception on an IOException connection failture 
changeset:   71596:fc12fc2621f1
Comment 6 Marian Mirilovic 2008-03-05 20:43:53 UTC
*** Issue 129333 has been marked as a duplicate of this issue. ***
Comment 7 Petr Dvorak 2008-03-06 15:53:24 UTC
*** Issue 129252 has been marked as a duplicate of this issue. ***
Comment 8 Marian Mirilovic 2008-03-16 19:11:14 UTC
I this issue has already been fixed on Collab side as well as workarounded on our side.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo