Bug 123467 - Improve keymap options panel
Improve keymap options panel
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Options&Settings
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Max Sauer
issues@platform
http://ui.netbeans.org/docs/ui/keymap...
: UI
: 42362 58955 67221 74807 77602 126122 136374 136788 139075 142581 151372 151656 (view as bug list)
Depends on: 140543
Blocks: 133913 136173 152193
  Show dependency treegraph
 
Reported: 2007-12-05 13:13 UTC by jrojcek
Modified: 2009-02-19 22:53 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jrojcek 2007-12-05 13:13:49 UTC
Problem description:

It is extremely painful to create a new key binding since NetBeans 4.1. The following is copied from user's email:
--
Lets say I want to bind ctrl-a to go to beginning of line (that's what emacs does). Here's what I have to do:
1. Locate the editor settings dialog
2. Select 'Insertion Point to End of Line'
3. Click Add
4. Hit ctrl-a.

At this point the dialog won't let me choose this option because it's already bound. This means I have to cancel this dialog, choose the conflicting binding, 
remove it, then go back to step 1. UGH! There needs to be a way to remove any overlapping bindings at step 4 so that I don't have to do this dance.
It would also be helpful to see what is not bound. 
--

Another issue is that the user cannot _search_ for actions by name or shortcut.

Solution:

A specific design of the new keymap option panel is TBD.
Comment 1 Antonin Nebuzelsky 2008-04-15 17:12:22 UTC
Reassigning to new module owner jskrivanek.
Comment 2 Ondrej Langr 2008-06-04 15:06:16 UTC
UI specification for new keymap option panel is available. See the URL field. 
Comment 3 Ondrej Langr 2008-06-11 10:15:33 UTC
*** Issue 136374 has been marked as a duplicate of this issue. ***
Comment 4 Ondrej Langr 2008-06-23 14:47:03 UTC
Is this still a plan for 6.5?
Comment 5 Jan Becicka 2008-07-14 12:07:49 UTC
Unfortunately this enhancement was postponed.
Comment 6 Jiri Skrivanek 2008-07-21 14:18:37 UTC
Also please consider unification of keymap option panel and toolbars customizer (see issue 139075).
Comment 7 Jiri Skrivanek 2008-07-21 14:27:02 UTC
*** Issue 139075 has been marked as a duplicate of this issue. ***
Comment 8 Jan Becicka 2008-08-07 15:12:09 UTC
*** Issue 74807 has been marked as a duplicate of this issue. ***
Comment 9 Martin Krauskopf 2008-08-07 17:26:25 UTC
Jano filed issue 74807 as a DEFECT, so if it is a dupe (really is?) of this one, this should be also DEFECT, right?
(also large number of dupes in 74807).
Comment 10 Jiri Skrivanek 2008-08-18 12:57:05 UTC
*** Issue 142581 has been marked as a duplicate of this issue. ***
Comment 11 Vitezslav Stejskal 2008-08-22 10:09:47 UTC
*** Issue 126122 has been marked as a duplicate of this issue. ***
Comment 12 Jiri Skrivanek 2008-09-02 10:35:07 UTC
*** Issue 136788 has been marked as a duplicate of this issue. ***
Comment 13 Jiri Skrivanek 2008-10-09 15:41:30 UTC
*** Issue 67221 has been marked as a duplicate of this issue. ***
Comment 14 Jiri Skrivanek 2008-10-09 16:34:01 UTC
*** Issue 77602 has been marked as a duplicate of this issue. ***
Comment 15 Jiri Skrivanek 2008-10-10 11:09:23 UTC
*** Issue 58955 has been marked as a duplicate of this issue. ***
Comment 16 Jiri Skrivanek 2008-10-17 13:07:08 UTC
*** Issue 42362 has been marked as a duplicate of this issue. ***
Comment 17 Ondrej Langr 2008-10-17 14:58:37 UTC
This issue has been reported at least 10 times, and I assume number of people were about to file it, but did find some
of the other duplicate issues before ;). 

Thus raising priority to P2. 
Comment 18 Quality Engineering 2008-10-22 15:44:05 UTC
Integrated into 'main-golden', will be available in build *200810221401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/5d50b807175f
User: Max Sauer <msauer@netbeans.org>
Log: #123467: Keymap options panel improvements
Comment 19 kawazu428 2008-10-23 08:07:04 UTC
Aaaaaaaaaaaaaaaaaaaaaaaaaaaaahhhhhhhhhhhhhhh.... Seen the implementation in recent nightly build. _Very_ pleasant,
that's pretty much like it should be! :)


Product Version: NetBeans IDE Dev (Build 200810230201)
Java: 1.6.0_10; Java HotSpot(TM) Client VM 11.0-b15
System: Linux version 2.6.24-21-generic running on i386; UTF-8; de_DE (nb)
Userdir: /home/kr/.netbeans/dev-6.5
Comment 20 Petr Dvorak 2008-10-23 08:10:16 UTC
*** Issue 150976 has been marked as a duplicate of this issue. ***
Comment 21 Quality Engineering 2008-10-24 04:20:22 UTC
Integrated into 'main-golden', will be available in build *200810240201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/43c2bfca5704
User: Max Sauer <msauer@netbeans.org>
Log: #123467: Keymap Option Panel improvements
Comment 22 Jana Maleckova 2008-10-26 21:33:39 UTC
*** Issue 151372 has been marked as a duplicate of this issue. ***
Comment 23 Petr Dvorak 2008-10-30 14:53:08 UTC
*** Issue 151656 has been marked as a duplicate of this issue. ***
Comment 24 Max Sauer 2008-11-05 16:09:51 UTC
Most of desired improvements (initial report, UI spec) have been already implemented, I'm marking this issue as FIXED.
Comment 25 Quality Engineering 2008-11-05 17:02:44 UTC
Integrated into 'main-golden', will be available in build *200811051401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/a6881ccf1599
User: Max Sauer <msauer@netbeans.org>
Log: #123467: Adding completion offering free shortcuts
Comment 26 Quality Engineering 2008-11-06 05:19:57 UTC
Integrated into 'main-golden', will be available in build *200811060201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/2513167636e5
User: Max Sauer <msauer@netbeans.org>
Log: #123467: Do not remember search state


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo