Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 110571 - To define the final list of modules which are visible in Autoupdate UI
To define the final list of modules which are visible in Autoupdate UI
Status: RESOLVED FIXED
Product: ide
Classification: Unclassified
Component: Code
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Pavel Buzek
issues@ide
http://wiki.netbeans.org/wiki/view/NB...
issue_reviewed
:
: 112455 (view as bug list)
Depends on:
Blocks: 110566
  Show dependency treegraph
 
Reported: 2007-07-23 12:46 UTC by Jiri Rechtacek
Modified: 2010-04-16 07:48 UTC (History)
1 user (show)

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Rechtacek 2007-07-23 12:46:12 UTC
To define the final list of visible module and its dependencies on hidden modules and get it reviewed and implemented,
for all modules in NetBeans and also supervise what gets into stable update center.
Comment 1 Pavel Buzek 2007-07-29 22:42:13 UTC
List of plugins is in wiki, see URL.
I am working on implementing the list in branch au_110566.
Comment 2 Pavel Buzek 2007-08-04 07:45:50 UTC
First cut of grouping is done for all modules in full netbeans build. Ready for the merge to trunk, the list of plugins
can be refined later in trunk based on feedback. Update center modules can be done later, maven and collaboration for
beta 1, the rest either for beta1 or beta 2.

I had to make a few minor changes to the original proposal, most notably to add "IDE Platform" and "NetBeans 6.0"
plugins. The reason is that I do not want any plugins to span multiple clusters so that these general purpose IDE
modules cannot be included into "Platform".

We will need a way to disable uninstall and disable operations on Platform plugin, I do not have a strong opinion about
how this should be done. Either hardcode it most pragmatic, IMO) or create a contract and use it in Platform plugin.

Update list of plugins, their content, depndencies, etc. is in http://wiki.netbeans.org/wiki/view/NB6VisiblePlugins
Comment 3 Jiri Rechtacek 2007-08-08 16:48:18 UTC
I marked the Collab modules.

Checking in chat/manifest.mf;
/shared/data/ccvs/repository/collab/chat/manifest.mf,v  <--  manifest.mf
new revision: 1.15; previous revision: 1.14
done
Checking in chat/html/manifest.mf;
/shared/data/ccvs/repository/collab/chat/html/manifest.mf,v  <--  manifest.mf
new revision: 1.6; previous revision: 1.5
done
Checking in chat/java/manifest.mf;
/shared/data/ccvs/repository/collab/chat/java/manifest.mf,v  <--  manifest.mf
new revision: 1.6; previous revision: 1.5
done
Checking in chat/text/manifest.mf;
/shared/data/ccvs/repository/collab/chat/text/manifest.mf,v  <--  manifest.mf
new revision: 1.6; previous revision: 1.5
done
Checking in chat/xml/manifest.mf;
/shared/data/ccvs/repository/collab/chat/xml/manifest.mf,v  <--  manifest.mf
new revision: 1.6; previous revision: 1.5
done
Checking in core/manifest.mf;
/shared/data/ccvs/repository/collab/core/manifest.mf,v  <--  manifest.mf
new revision: 1.7; previous revision: 1.6
done
Checking in filesharing/manifest.mf;
/shared/data/ccvs/repository/collab/filesharing/manifest.mf,v  <--  manifest.mf
new revision: 1.23; previous revision: 1.22
done
Checking in im/manifest.mf;
/shared/data/ccvs/repository/collab/im/manifest.mf,v  <--  manifest.mf
new revision: 1.12; previous revision: 1.11
done
Checking in kit/manifest.mf;
/shared/data/ccvs/repository/collab/kit/manifest.mf,v  <--  manifest.mf
new revision: 1.3; previous revision: 1.2
done
Checking in moxc/manifest.mf;
/shared/data/ccvs/repository/collab/moxc/manifest.mf,v  <--  manifest.mf
new revision: 1.4; previous revision: 1.3
done
Checking in output/manifest.mf;
/shared/data/ccvs/repository/collab/output/manifest.mf,v  <--  manifest.mf
new revision: 1.6; previous revision: 1.5
done
Checking in ui/manifest.mf;
/shared/data/ccvs/repository/collab/ui/manifest.mf,v  <--  manifest.mf
new revision: 1.26; previous revision: 1.25
done
Comment 4 Jiri Rechtacek 2007-08-09 14:30:28 UTC
*** Issue 112455 has been marked as a duplicate of this issue. ***
Comment 5 Lukas Hasik 2008-04-10 21:34:27 UTC
moving opened issues from TM <= 6.1 to TM=Dev
Comment 6 Jana Maleckova 2008-09-16 09:24:27 UTC
Please could you update this issue ? pbuzek is no longer in sun. Does anybody know who is now responsible for this ?
Comment 7 Peter Pis 2008-11-03 09:46:53 UTC
Can it be closed as FIXED?
Comment 8 Jiri Rechtacek 2008-11-03 09:50:28 UTC
Who knows? It's a permanent task.
Comment 9 Marian Mirilovic 2010-04-16 07:48:37 UTC
too old


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo