Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 106455 - does not install ruby
does not install ruby
Status: VERIFIED FIXED
Product: installer
Classification: Unclassified
Component: NBI
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Kirill Sorokin
issues@installer
:
: 107952 (view as bug list)
Depends on:
Blocks: 106361
  Show dependency treegraph
 
Reported: 2007-06-13 05:58 UTC by Ken Frank
Modified: 2007-06-26 15:50 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
log (1.74 MB, text/plain)
2007-06-13 05:59 UTC, Ken Frank
Details
Installation log (760.71 KB, text/plain)
2007-06-21 14:23 UTC, novakm
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ken Frank 2007-06-13 05:58:13 UTC
using 06121200 installer, full installer - am in ja locale but its always installed ruby before and
am not using any pseudo localized nbi msgs at all.

am on solaris sparc.

attached is nbi log file.
Comment 1 Ken Frank 2007-06-13 05:59:45 UTC
Created attachment 43588 [details]
log
Comment 2 dlipin 2007-06-13 14:59:54 UTC
Ken,

Does this issue occur in posix (C) locale?
Is the issue 100% reproducible in ja locale (could you please try to reinstall the same build after cleaning the 
previous installations and ~/.nbi directory as well)?
Please check that Ruby is listed at the Welcome page (that meens that it would be installed) among all other features.

Dmitry
Comment 3 Ken Frank 2007-06-13 16:47:14 UTC
am not able to try it now in c locale; does it happen to others on solaris doing recent installs ?
if it does not happen to others in c locale then yes I should try it in c locale.

as to 100 % - it happened using 0612000 also, and before I did 06121200 I did remove .nbi contents.

ruby is listed on welcome page and on final panell where it summarizes what is to be installed.

ken.frank@sun.com
Comment 4 novakm 2007-06-21 13:14:27 UTC
I am afraid it's not problem of specific locale. I have Windows Vista with EN locale and my full installer
(200706190000-full) doesn't install Ruby even it is checked and listed in features to be installed. It is 100%
reproducible and P1 IMHO.
Comment 5 dlipin 2007-06-21 13:17:41 UTC
ok, i`ll check it now.
Comment 6 Sergey Lunegov 2007-06-21 13:21:06 UTC
 novakm, please attachthe installation log.
Comment 7 dlipin 2007-06-21 13:45:16 UTC
reproduced. investigating...
Comment 8 novakm 2007-06-21 14:23:17 UTC
Created attachment 44171 [details]
Installation log
Comment 9 dlipin 2007-06-21 14:33:19 UTC
Something wrong with FilesList class.
Ruby has about 2.7K files and this list can`t be proceeded correctly.... other products doesn`t handle so big amount of
files and installed correctly.
Comment 10 Ken Frank 2007-06-22 05:31:11 UTC
06210000 on solaris also does not install soa1

also, it installs cnd but cnd is not given as a choice.

ken.frank@sun.com
Comment 11 Ken Frank 2007-06-22 05:53:15 UTC
also noticed that gf of this install does not have the addons dir that has amserver, etc.

ken.frank@sun.com
Comment 12 Kirill Sorokin 2007-06-25 05:56:30 UTC
*** Issue 107952 has been marked as a duplicate of this issue. ***
Comment 13 Kirill Sorokin 2007-06-25 12:18:51 UTC
Dmitry's diagnosis was correct the temporary serialization routine was faulty. This is now fixed, committed to both
{trunk} and {release60-m10}.
Comment 14 Peter Pis 2007-06-26 08:55:12 UTC
To Reporter: Could you please verify this issue? Thanks.
Comment 15 Tomas Danek 2007-06-26 15:21:29 UTC
following works for me:

- downloaded m10 full installer (200706251444)
- chose base ide, java ide, and ruby to install
- ruby cluster was installed ok.
Comment 16 mariadavydova 2007-06-26 15:50:43 UTC
verified with NetBeans IDE 6.0 Build 200706260050


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo