Bug 96727 - Accessing accesscontrolled updatecenters
Accessing accesscontrolled updatecenters
Status: RESOLVED WORKSFORME
Product: platform
Classification: Unclassified
Component: Autoupdate
6.x
All All
: P2 with 2 votes (vote)
: TBD
Assigned To: Jaroslav Tulach
issues@platform
:
Depends on:
Blocks: 145901
  Show dependency treegraph
 
Reported: 2007-02-27 22:00 UTC by sreimers
Modified: 2010-10-13 11:24 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sreimers 2007-02-27 22:00:49 UTC
Up to now it was possible to access updatecenters with user authentication due
to handling code inside NbAuthenticator. The last changes seem to correct those
perhaps unwanted side effects, but now it is not possible to enter
authentication information on an authentication challenge sent from the server.

Since there is no eays way to do this now a quick solution would be appreciated.
Comment 1 tomwheeler 2008-09-26 17:44:55 UTC
I found this issue while trying to help someone on the dev@openide list who wanted to do the same thing.  From my
research, I found this is a somewhat common request but has no good solution so I have voted for the issue to reflect that.

The approaches that seem possible without this RFE seem to be (just speculation as I have not tried either one):

1.  You could create and register an instance of UpdateProvider.  When that UpdateProvider is requested to provide
information, it could attempt to authenticate the user, then parse the data from the update center URL (e.g. the XML
file) and then return the requested information.  This would be cumbersome but would allow a lot of flexibility (the
update center info could actually reside in a database, for example).

2.  You could create a ModuleInstall class which registers your own java.net.Authenticator as the default, and it could
pay attention to the requested URL.  If the URL for your password-protected update center was requested, then it could
prompt for authentication for that UC; otherwise it could delegate to the normal org.netbeans.core.NbAuthenticator that
NetBeans installs.  But since the NbAuthenticator is not part of a public API, you would have to access it via
reflection and this would be fragile.  It also might not work well (or at least be more difficult) if the user has a
password-protected proxy server.

Comment 2 Antonin Nebuzelsky 2008-11-14 15:32:29 UTC
Reassigning to the new "autoupdate/*" owner dlipin.
Comment 3 Jaroslav Tulach 2010-10-13 11:24:55 UTC
Give me some testcase or a way to reproduce the problem, please.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo