Bug 145901 - Let me sell my plugin through plugin manager
Let me sell my plugin through plugin manager
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: Plugin Manager
6.x
PC Windows XP
: P1 (vote)
: TBD
Assigned To: Jaroslav Tulach
au-issues
:
: 136017 (view as bug list)
Depends on: 96727
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-02 12:32 UTC by Lukas Hasik
Modified: 2010-10-07 18:22 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Hasik 2008-09-02 12:32:41 UTC
there is a plenty of developers creating plugins for the NetBeans IDE (look at pluginportal). Why we could not offer a
way for those developers to sell their work to NB users? Right now they provide everything for free. IMO, a payback for
their hard work would be highly appreciated from both sides - users and developers. Everybody would profit because
1, developers could invest more time into the developement (they will get some money from users that will pay their work
investment)
2, users will get more stable product with more features (because the developers can spent more time on the developement)
3, netbeans can be the provider that should receive a "small profit too, as any other distributor.

This idea come up when I read following articles about Android Store:
http://android-developers.blogspot.com/2008/08/android-market-user-driven-content.html
http://weblog.cenriqueortiz.com/mobility/2008/08/28/google-introduces-android-market-the-google-app-store-for-android/


IMO, that's model that we could easily follow. What we need to solve/implement:
1, let users to rank plugins (from IDE)
2, we need to setup a DRM for modules
3, distribution channels
4, payment for the plugins
Comment 1 Jiri Rechtacek 2008-10-16 16:55:16 UTC
*** Issue 136017 has been marked as a duplicate of this issue. ***
Comment 2 Antonin Nebuzelsky 2008-11-14 15:31:39 UTC
Reassigning to the new "autoupdate/*" owner dlipin.
Comment 3 Jaroslav Tulach 2010-10-07 18:22:51 UTC
Yeah, this would be cool. Who's going to do it?


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo