Bug 94930 - I18N: Chinese/Japanese chars display squares on Ubuntu 6.06
I18N: Chinese/Japanese chars display squares on Ubuntu 6.06
Status: RESOLVED INVALID
Product: ide
Classification: Unclassified
Component: Code
5.x
PC Linux
: P1 (vote)
: TBD
Assigned To: issues@ide
issues@ide
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-08 09:59 UTC by Will Zhang
Modified: 2007-02-09 11:29 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
snapshot (60.18 KB, application/octet-stream)
2007-02-08 10:23 UTC, Will Zhang
Details
snapshot (58.22 KB, application/octet-stream)
2007-02-08 10:24 UTC, Will Zhang
Details
Japanese. IDE works in 6.10 (249.27 KB, image/png)
2007-02-09 10:28 UTC, Keiichi Oono
Details
Simplified Chinese. IDE works in 6.10 (268.60 KB, image/png)
2007-02-09 10:29 UTC, Keiichi Oono
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Will Zhang 2007-02-08 09:59:32 UTC
OS: Ubuntu 6.06
locale: zh_CN.UTF-8/ja_JP.UFT-8
jdk: 1.6.0/1.5.0U11

reproduce:
install nb5.5, Chinese/Japanese chars display squares 
see attachment for detail
Comment 1 Keiichi Oono 2007-02-08 10:18:13 UTC
component "i18n" is not internationalization, but I18n support feature in the
IDE. Change component from "i18n" to "ide".
Comment 2 Will Zhang 2007-02-08 10:23:19 UTC
Created attachment 38225 [details]
snapshot
Comment 3 Will Zhang 2007-02-08 10:24:11 UTC
Created attachment 38226 [details]
snapshot
Comment 4 Will Zhang 2007-02-08 10:42:22 UTC
Ubuntu will be offical support Linux platform for nb5.5.1 and all nb5.5.1 
packs sitting on the top of nb.
Ubuntu is not the offical support Linux platform by JDK.
This issue is similar with nb5.5 with FC3, see CR6493994, 
http://bt2ws.central.sun.com/CrPrint?id=6493994
We need to note in Supported Operating Systems of RN that Ubuntu 6.x (except 
when running in the zh_CN/JA locale and possibly other Asian locales) 
L10N team only test nb5.5.1 and packs on RH Ent4 for Linux platform.
Comment 5 Ken Frank 2007-02-08 15:18:37 UTC
Will,

This isnt a bug since, like fedora core, the jdk does not support ubuntu
as to the font support, etc. 

But we have explicitly added RH EL4 to supported platforms list
since jdk font support is supported for that OS.

ken.frank@sun.com
Comment 6 Will Zhang 2007-02-09 00:51:47 UTC
Ken,

For nb5.5.1 and all packs sitting on the top of it, RH EL4 is the only 
supported Linux platform for ja/zh and this issue also will be noted in RN, 
correct?
But for other language, e.g, pt_BR, that don't have this issue, pt_BR l10n 
team need to do full testing on ubuntu and sanity testing on RH EL4. In other 
words, they will have two Linux platform for testing, right?

Comment 7 Masaki Katakai 2007-02-09 01:53:57 UTC
I'd like to ask Janice and Ken to raise this issue at NB core team meeting
and want to hear their comments and (personally I'd like to know) the
reason why Ubuntu is added as new platform.

I agree that we will test just RHEL4 and provide the description into RN,
actually RN has already such description at 5.5 release, it's OK. But we
should provide the possible workaround into FAQ and other places.
The workaround for font issue are very common, so they can use
NB and other packs at their own risk.
Comment 8 Ken Frank 2007-02-09 04:06:26 UTC
Will,

no, even for pt br its not supported since jdk does not support
ubuntu as to other fonts; 

also, as we discovered for nb 55, this can be mentioned in rel notes but
we should not provide workarounds officially since that means you
are asking user to create a customized jdk.

I dont think this is any different from situation we saw in 55 whether for
ja zh or pt br ?

ken.frank@sun.com
Comment 9 Will Zhang 2007-02-09 04:30:34 UTC
Ken,

I see, 
L10n team only need to do the nb5.5.1 testing on RHEL4, but not Ubuntu.
This will be noted in RN as nb5.5
No official workround
Yes, the situation is total similar with nb5.5
Comment 10 Keiichi Oono 2007-02-09 10:26:51 UTC
Hi Will and all,

Which JDK are you using?
I've tested NetBeans IDE 5.5 in Ubuntu 6.10 desktop, and multi-byte characters
are displayed correctly. Would you review my steps, and try in your environment?

Install JDK
-----------

Edit /etc/apt/sources.list
You can see the following two comment lines (URL should be different in your
default language)

# deb http://jp.archive.ubuntu.com/ubuntu/ dapper universe
# deb-src http://jp.archive.ubuntu.com/ubuntu/ dapper universe

Remove '#', and add 'multiverse' because sun-java5-jdk package is located at
multiverse. Please see: http://packages.ubuntu.com/dapper/devel/sun-java5-jdk
The two lines should like follows:

deb http://jp.archive.ubuntu.com/ubuntu/ dapper universe multiverse
deb-src http://jp.archive.ubuntu.com/ubuntu/ dapper universe multiverse

Install package:

   # apt-get update
   # apt-get install sun-java5-jdk

JDK is installed into:
/usr/lib/jvm/java-1.5.0-sun

Install NetBeans IDE
--------------------
Now,you can install NetBeans by executing Linux installer. No additional
configuration is needed. I will attach the screen shot for images.

Environment information:
   OS: Ubuntu 6.10 Desktop
   Java: sun-java5-jdk (1.5.0_08)
   IDE: NetBeans 5.5

Ubuntu 6.10 can be a supported platform for ja and zh_CN.
Comment 11 Keiichi Oono 2007-02-09 10:28:35 UTC
Created attachment 38280 [details]
Japanese. IDE works in 6.10
Comment 12 Keiichi Oono 2007-02-09 10:29:25 UTC
Created attachment 38281 [details]
Simplified Chinese. IDE works in 6.10
Comment 13 Keiichi Oono 2007-02-09 10:41:22 UTC
Let me correct my previous comment. The 'supported platform' is not good word.
What I would like to say is:

NetBeans IDE can be used in Ubuntu 6.10 Japanese and Simplified Chinese
environment by installing sun-java5-jdk package as described in this report.

It does not mean 'supported platform'.
Comment 14 Will Zhang 2007-02-09 11:29:57 UTC
Hi Keiichi,

I downloaded the JDK1.5.0_11/JDK1.6.0 from java.sun.com and install them on 
Ubuntu manually. I think many users would use the same way to install the JDK, 
since JDK will not be installed as default when you install Ubuntu.
At the same time, it's really a good solution to try ml nb and packs on Ubuntu.
If we can't add it in RN, maybe we might publish it on locale SDN or other 
place to let users know it.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo