Bug 93858 - Startup looking for jaxws21\api with over-appended path
Startup looking for jaxws21\api with over-appended path
Status: RESOLVED DUPLICATE of bug 95796
Product: platform
Classification: Unclassified
Component: Filesystems
6.x
All All
: P3 (vote)
: 6.x
Assigned To: rmatous
issues@platform
: SPACE_IN_PATH
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-01 20:19 UTC by ssoong
Modified: 2008-12-22 11:38 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Looking for file using over-appended path (11.97 KB, image/jpeg)
2007-02-01 20:20 UTC, ssoong
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ssoong 2007-02-01 20:19:07 UTC
NetBeans IDE Dev (Build 200701301900)
1.5.0_05; Java HotSpot(TM) Client VM 1.5.0_05-b05
Windows XP version 5.1 running on x86
=================================================

At NB Startup, an errro notice pops up looking for file not found:
C:\Program Files\netbeans\6.0\200701301900\Files\netbeans\6.0\200701301900\ide8
\modules\ext\jaxws21\api

It think it meant to look for:
C:\Program Files\netbeans\6.0\200701301900\ide8\modules\ext\jaxws21\api.

Notice that "Files\netbeans\6.0\200701301900\" over-appended.

I looked at 
C:\Program Files\netbeans\6.0\200701301900\ide8\modules\ext\jaxws21\api
and found two jars: jaxb-api and jaxws-api.

This happened after I treated Issue 93847 by deleting the problematic project 
and recreated it successfully, and then restarting netbeans. Now it shows up 
everytime I restart netbeans.
Comment 1 ssoong 2007-02-01 20:20:32 UTC
Created attachment 37940 [details]
Looking for file using over-appended path
Comment 2 Jiri Prox 2007-02-05 10:22:26 UTC
Is there in the mentioned project or other locations in IDE (e.g. Favorites Tab,
Libraries ...) any reference to this path? 
Comment 3 ssoong 2007-02-09 16:05:16 UTC
The message comes up even when I start nb with a virgin ide env -
i.e. no [C:\Documents and Settings\user\dev] folder, no projects.
Therefore no favourites, no tabs, no Libraries, no extra modules.

It is still there at Build 200702081900.
Comment 4 ssoong 2007-02-09 16:14:08 UTC
Therefore, it is probably unrelated to Issue 93847.
It is probably coincidental to my move to build 200701301900.
Comment 5 ssoong 2007-02-09 16:25:45 UTC
Hah! I found the problem.
I copied the whole netbeans folder to D:/temp/200702081900
At which I ran netbeans and the message did not appear.

However the message
[D:\temp\Eclipse Sucks\200702081900\Sucks\200702081900\ide8\modules\ext\jaxws21
\api does not exist ....]
when I moved and ran netbeans at D:\temp\Eclipse Sucks\200702081900.

I tried every instance where path has a space char and the message pops up.

Which means, somewhere in NB6 code (for builds on and after 200701301900) is a 
space-char unfriendly routine.


Comment 6 _ rkubacki 2007-02-22 17:28:58 UTC
duplicate

*** This issue has been marked as a duplicate of 95796 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo