Bug 95796 - Strange information message each NB startup
Strange information message each NB startup
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: -- Other --
6.x
PC Windows XP
: P3 (vote)
: 6.x
Assigned To: _ rkubacki
issues@platform
: SPACE_IN_PATH
: 93858 95197 95494 96097 96339 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-16 12:21 UTC by Alexander Kouznetsov
Modified: 2008-12-22 11:51 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
screenshot (6.65 KB, image/png)
2007-02-16 12:22 UTC, Alexander Kouznetsov
Details
Log file (22.86 KB, text/plain)
2007-02-16 12:24 UTC, Alexander Kouznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kouznetsov 2007-02-16 12:21:12 UTC
NetBeans IDE Dev (Build 200702151900)
1.6.0; Java HotSpot(TM) Client VM 1.6.0-b105
Windows XP version 5.1 running on x86
ru_RU (nb); Cp1251

Each time I start NB, it shows me strange information message: "C:\Program
Files\NetBeans 6.0 Dev\Files\NetBeans does not exist, or is not a plain file."
The message is shown right after splash screen has been disappeared and before
main NB window is shown.
Comment 1 Alexander Kouznetsov 2007-02-16 12:22:01 UTC
Created attachment 38606 [details]
screenshot
Comment 2 Alexander Kouznetsov 2007-02-16 12:24:15 UTC
Created attachment 38607 [details]
Log file
Comment 3 Marian Mirilovic 2007-02-19 10:54:48 UTC
I think you had opened some project and some file no more exists (in this case
looks like directory). 
Could you please try to reproduce this with new user directory ? Also please
check whether file "C:\Program Files\NetBeans 6.0 Dev\Files\NetBeans" exists. I
don't see error in your message.log file.

Another possible problem could be locale, but I think this isn't NB issue.
Comment 4 Alexander Kouznetsov 2007-02-19 11:02:07 UTC
This is reproduced with cleaned userdir as well. There is no such file in a
filesystem. The issue is reproduced with at least two WinXP systems.
Comment 5 _ gtzabari 2007-02-19 16:57:01 UTC
*** Issue 95197 has been marked as a duplicate of this issue. ***
Comment 6 _ gtzabari 2007-02-19 16:57:32 UTC
*** Issue 95494 has been marked as a duplicate of this issue. ***
Comment 7 _ gtzabari 2007-02-19 16:59:03 UTC
I also see this on a clean userdir.
Comment 8 Jesse Glick 2007-02-19 20:35:18 UTC
Again as in #95197,

WARNING [org.netbeans.modules.java.source.usages.RepositoryUpdater]: No MasterFS
for file system root: D:\
WARNING [org.netbeans.modules.java.source.usages.RepositoryUpdater]: No MasterFS
for file system root: M:\

looks suspicious. Still no idea what actual code is producing this message nor
how to reproduce on an arbitrary machine. Probably Windows-specific.
Comment 9 Jan Lahoda 2007-02-19 21:13:46 UTC
The messages seems to be generated by the openfile in the utilities module. It
seems to me like a possible problem in:
ide/launcher/windows/netbeans.cpp

where the command line option created in function:
readEndorsedDirs
contains quoted directory reference, but the command line option as a whole is
quoted again on line 141 - which I think de-quotes the directory references again.

Radim, could you please check this? Thanks.
Comment 10 _ rkubacki 2007-02-19 22:34:05 UTC
My change to netbeans.exe mentioned by Honza Lahoda was integrated 2007/1/30
10:8:50. Can someone confirm that the problem appeared at this time?

If it didn't I can help by providing debug version of launchers to print startup
parameters to console so that we can find what is the problem
Comment 11 Jaroslav Pospisil 2007-02-20 08:04:30 UTC
I think it could be round that time because all previous january builds I tested
were fine in this matter.I'll try builds from 29.1. and 1.2. 
Comment 12 _ rkubacki 2007-02-20 10:13:04 UTC
Honza was correct and after removal of quoting in readEndorsedDirs the whole
'-J-Djava.endorsed.dirs=some path maybe with spaces' is now passed as one argument.

Now we need to check if it affects also 5.5.1 builds if they are installed to a
path with spaces (I'm afraid it does) and someone needs to decide if this should
be fixed before beta / after beta / ignore (there is a plan to remove this
endorsed dirs processing completely if we find better way how to fix related
problems). jpospisil: can you check this?
Comment 13 _ rkubacki 2007-02-20 10:14:12 UTC
Checking in netbeans.exe;
/shared/data/ccvs/repository/ide/launcher/windows/netbeans.exe,v  <--  netbeans.exe
new revision: 1.26; previous revision: 1.25
done
Checking in nb.exe;
/shared/data/ccvs/repository/ide/launcher/windows/nb.exe,v  <--  nb.exe
new revision: 1.26; previous revision: 1.25
done
Checking in netbeans.cpp;
/shared/data/ccvs/repository/ide/launcher/windows/netbeans.cpp,v  <--  netbeans.cpp
new revision: 1.29; previous revision: 1.28
done
Comment 14 Jaroslav Pospisil 2007-02-20 16:05:32 UTC
Yesterday's build was O.K., as you can see in issue 91346(same reason as here).
I'll check Beta.,but wonder if something changed.
Comment 15 Jaroslav Pospisil 2007-02-20 16:20:09 UTC
I tested today's NB5.5.1 Beta build and everything's O.K. 
Comment 16 Jaroslav Pospisil 2007-02-20 16:52:09 UTC
BTW - NB5.5.1 is installed in WinXP by default in path with one space 
("..Program files.."). 
NB6.0 has default path with three spaces ("C:\Program Files\NetBeans 6.0 Dev")
I tested even variant,when I reformed 5.5.1's path according to NB6.0 form with
three spaces,but in 5.5.1 the problem never occured,so I think its cause must be
something,what is only in NB6.0. I'll try to track first build,where the problem
happens,but for as I know,I've seen this issue first time 9th of february,when
no endorsed fix was in trunk yet.
Comment 17 _ rkubacki 2007-02-22 09:19:38 UTC
I forgot to close this one.
Comment 18 _ rkubacki 2007-02-22 17:28:54 UTC
*** Issue 93858 has been marked as a duplicate of this issue. ***
Comment 19 Milan Kuchtiak 2007-02-26 15:34:46 UTC
*** Issue 96097 has been marked as a duplicate of this issue. ***
Comment 20 _ rkubacki 2007-02-28 15:49:07 UTC
*** Issue 96339 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo