Bug 91495 - I18N - UML does not function under Arabic locale
I18N - UML does not function under Arabic locale
Status: RESOLVED FIXED
Product: uml
Classification: Unclassified
Component: General
5.x
PC All
: P2 (vote)
: 6.x
Assigned To: issues@uml
issues@uml
EXT-USER
: I18N
: 85880 95549 96708 102830 116498 121460 130799 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-22 16:38 UTC by hajal
Modified: 2008-06-26 22:37 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
messages.log file (206.72 KB, text/html)
2006-12-22 16:43 UTC, hajal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description hajal 2006-12-22 16:38:51 UTC
i am having this error while using The UML nbm in netbeans5.5 Please help asap :

A java.lang.NullPointerException exception has occurred.
Please report this at http://www.netbeans.org/community/issues.html,
including a copy of your messages.log file as an attachment.
The messages.log file is located in your C:\Documents and
Settings\Administrator\.netbeans\5.5\var\log folder.

and the following are details:
java.lang.NullPointerException
	at
org.netbeans.modules.uml.ui.swing.drawingarea.ADDrawingAreaControl.enterModeFromButton(ADDrawingAreaControl.java:4584)
	at
org.netbeans.modules.uml.palette.PaletteSupport$PalettePropertyChangeListener.propertyChange(PaletteSupport.java:176)
	at
java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:339)
	at
java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:276)
	at
org.netbeans.spi.palette.PaletteController$1.propertyChange(PaletteController.java:159)
	at
java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:339)
	at
java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:276)
	at org.netbeans.modules.palette.DefaultModel.setSelectedItem(DefaultModel.java:92)
	at org.netbeans.modules.palette.ui.PalettePanel.select(PalettePanel.java:236)
	at
org.netbeans.modules.palette.ui.CategoryDescriptor$2.valueChanged(CategoryDescriptor.java:91)
	at javax.swing.JList.fireSelectionValueChanged(JList.java:1675)
	at javax.swing.JList$ListSelectionHandler.valueChanged(JList.java:1689)
	at
javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:187)
	at
javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:167)
	at
javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:214)
	at
javax.swing.DefaultListSelectionModel.changeSelection(DefaultListSelectionModel.java:408)
	at
javax.swing.DefaultListSelectionModel.changeSelection(DefaultListSelectionModel.java:417)
	at
javax.swing.DefaultListSelectionModel.setSelectionInterval(DefaultListSelectionModel.java:441)
	at javax.swing.JList.setSelectionInterval(JList.java:1962)
	at
javax.swing.plaf.basic.BasicListUI$Handler.adjustSelection(BasicListUI.java:2704)
	at javax.swing.plaf.basic.BasicListUI$Handler.mousePressed(BasicListUI.java:2667)
	at
javax.swing.plaf.basic.BasicListUI$MouseInputHandler.mousePressed(BasicListUI.java:1496)
	at
org.netbeans.modules.palette.ui.CategoryList$CategoryListUI$ListMouseInputHandler.mousePressed(CategoryList.java:409)
	at java.awt.AWTEventMulticaster.mousePressed(AWTEventMulticaster.java:222)
	at java.awt.AWTEventMulticaster.mousePressed(AWTEventMulticaster.java:221)
	at java.awt.AWTEventMulticaster.mousePressed(AWTEventMulticaster.java:221)
	at java.awt.Component.processMouseEvent(Component.java:5996)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3240)
	at java.awt.Component.processEvent(Component.java:5764)
	at java.awt.Container.processEvent(Container.java:1984)
	at java.awt.Component.dispatchEventImpl(Component.java:4407)
	at java.awt.Container.dispatchEventImpl(Container.java:2042)
	at java.awt.Component.dispatchEvent(Component.java:4237)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4248)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3909)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3842)
	at java.awt.Container.dispatchEventImpl(Container.java:2028)
	at java.awt.Window.dispatchEventImpl(Window.java:2405)
	at java.awt.Component.dispatchEvent(Component.java:4237)
[catch] at java.awt.EventQueue.dispatchEvent(EventQueue.java:600)
	at
java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:173)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:168)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:160)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)
Comment 1 hajal 2006-12-22 16:43:53 UTC
Created attachment 36905 [details]
messages.log file
Comment 2 hajal 2006-12-22 16:46:43 UTC
the problem happened after adding them.
Comment 3 Trey Spiva 2007-01-02 13:58:32 UTC
Can you give us a little more information?  From the exeception it looks like you pressed a button on the 
toolbar, or on the palette.  can you tell me which button was selected?  Also, what diagram where you 
using?
Comment 4 hajal 2007-01-03 16:29:26 UTC
i used my administrator account to update netbeans with UML nbm.
then i created a new Uml Project , and seleted the use case diagram.
The new diagram was grey as if disabled. When i try to select something from the
palette a red stop sign signals in the lower right corner of my IDE with the
errors i mentioned.

Ps: i noticed that when i use a different user with no administrative priveliges
, the project runs fine .

Please advise. Thanks .
Comment 5 Yang Su 2007-01-03 18:53:19 UTC
Your log file indicates you were using ar_LB locale, UML uses TomSawyer drawing
library which has a known issue with Arabic encoding, see
http://forum.java.sun.com/thread.jspa?forumID=747&threadID=5060088

It fails at the license validation. The workaround is to start IDE under en
locale, you mentioned you didn't have the problem with a different user account,
it could be that account has a different locale setting.
Comment 6 hajal 2007-01-09 17:12:58 UTC
thanks sherylSU. For solving the problem.
Comment 7 Sergey Petrov 2007-02-12 12:10:30 UTC
In my opinion the issue isn't fixed but has a workaround
Comment 8 Andrew Korostelev 2007-02-14 13:51:25 UTC
see also issue 95549 - diagram drawing area is not shown if ar_SA locale is used
Comment 9 Andrew Korostelev 2007-02-15 09:48:28 UTC
*** Issue 95549 has been marked as a duplicate of this issue. ***
Comment 10 Ken Frank 2007-02-16 19:29:15 UTC
The workaround to start in en locale wont help users who need to be in 
their own locale.  Is this still a problem in curent griffin uml ?

ken.frank@sun.com
Comment 11 Yang Su 2007-02-27 19:19:06 UTC
*** Issue 96708 has been marked as a duplicate of this issue. ***
Comment 12 Yang Su 2007-03-26 23:17:45 UTC
*** Issue 85880 has been marked as a duplicate of this issue. ***
Comment 13 Yang Su 2007-04-27 21:33:06 UTC
*** Issue 102830 has been marked as a duplicate of this issue. ***
Comment 14 Yang Su 2007-07-12 01:05:17 UTC
This is directly caused by TomSawyer license validation logic failing on Arabic locale, the plan is to migrate to new NB
drawing library Meteora, this should be waived for NB6.0 release then.
Comment 15 George Vasick 2007-07-13 16:26:00 UTC
Waiver candidates from 7/12/2007 bug scrub.
Comment 16 George Vasick 2007-07-13 16:34:49 UTC
Waiver candidates from 7/12/2007 bug scrub.
Comment 17 Yang Su 2007-10-01 23:01:15 UTC
*** Issue 116498 has been marked as a duplicate of this issue. ***
Comment 18 Ken Frank 2007-10-02 03:12:22 UTC
is Tom Sawyer lib still used for uml for nb6 ?

ken.frank@sun.com
Comment 19 Peter Lam 2007-10-02 17:28:51 UTC
for NB6.0, yes.
Comment 20 Ken Frank 2007-10-02 18:09:57 UTC
is there a way the license check can be intercepted and then correct the problem characters ?

since am assuming there is some uml code that then calls tom sawyer licensing code ?

ken.frank@sun.com
Comment 21 Yang Su 2007-11-15 00:30:23 UTC
*** Issue 121460 has been marked as a duplicate of this issue. ***
Comment 22 George Vasick 2008-01-15 22:04:51 UTC
Reviewed and approved for waiver by UML -iteam.
Comment 23 George Vasick 2008-03-24 23:46:50 UTC
*** Issue 130799 has been marked as a duplicate of this issue. ***
Comment 24 Peter Lam 2008-05-23 19:44:43 UTC
In ar_SA locale, here's the result of verification in NB 6.5.

# work in diagram drawing area for the currently supported 5 diagram types: activity, class, sequence, state, use case
# Arabic characters can be entered in element names, attributes, operations
# typing in invocation & signal elelements in activity diagram is not visible till Enter is pressed then typed text
showed up
# typing in comment element in any diagram type is not visible till Enter to show up
Comment 25 George Vasick 2008-06-06 00:39:29 UTC
I18N support is targeted for 6.5M2.
Comment 26 Trey Spiva 2008-06-26 22:37:06 UTC
Since we are now using the NetBeans Visual Library this should not longer be a problem.  Please retest this issue.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo