Bug 95549 - diagram drawing area is not shown if ar_SA locale is used
diagram drawing area is not shown if ar_SA locale is used
Status: RESOLVED DUPLICATE of bug 91495
Product: uml
Classification: Unclassified
Component: General
5.x
All All
: P2 (vote)
: 6.x
Assigned To: issues@uml
issues@uml
EXT-USER
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-14 13:50 UTC by Andrew Korostelev
Modified: 2008-05-23 19:44 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Korostelev 2007-02-14 13:50:00 UTC
user heshamz@yahoo.com has written to issues@uml.netbeans.org.

NetBeans 5.5.
WindowsXP SP2

when I try to create a UML project and create a new diagram 
the diagram window appears but the draw area for the diagram (the white
background) doesn't, 
thus, I can't draw anything on the diagram.
If I close it I can't reopen it again.

This happend wither the diagram created with the project or afterwards.
Also I have the same problem with UML inside Sun Studio Enterprise.

I think I found out the problem, my locale is "ar_SA", 
if I change the local of windows xp to be "en_US" the diagrams work fine, 
but if I change it to anything else even in english "en_XX" 
the UML diagram is stop working.
Comment 1 Andrew Korostelev 2007-02-14 13:51:25 UTC
see also issue 91495 - UML does not function under Arabic locale
Comment 2 Andrew Korostelev 2007-02-15 09:48:35 UTC
user agreed this this issue is a duplicate of 91495

*** This issue has been marked as a duplicate of 91495 ***
Comment 3 Peter Lam 2008-05-23 19:43:16 UTC
In ar_SA locale, here's the result of verification in NB 6.5.
# work in diagram drawing area for the currently supported 5 diagram types: activity, class, sequence, state, use case
# Arabic characters can be entered in element names, attributes, operations
# typing in invocation & signal elelements in activity diagram is not visible till Enter is pressed then typed text
showed up
# typing in comment element in any diagram type is not visible till Enter to show up
Comment 4 Peter Lam 2008-05-23 19:44:43 UTC
ops, the comment is meant to be in issue 91495, but it's good for this also.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo