Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 90221 - cannot register current V2 domains
cannot register current V2 domains
Status: VERIFIED FIXED
Product: serverplugins
Classification: Unclassified
Component: Sun Appserver 9
5.x
PC Linux
: P3 (vote)
: 6.x
Assigned To: Vince Kraemer
issues@serverplugins
GFV2, release55_fixes_fixed
:
: 90604 90798 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-28 19:55 UTC by Vince Kraemer
Modified: 2007-02-19 11:56 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vince Kraemer 2006-11-28 19:55:30 UTC
root cause: https://glassfish.dev.java.net/issues/show_bug.cgi?id=1595
Comment 1 Vince Kraemer 2006-11-28 19:58:09 UTC
this is a tracking bug....  
Comment 2 Vince Kraemer 2006-11-29 01:19:47 UTC
GF V2 build 26 [28-Nov-2006]
Comment 3 Vince Kraemer 2006-12-01 01:04:17 UTC
work-around...

1. install glassfish (java -jar then ant -f setup.xml)
2. use your favorite editor to open
  <gfinstall>/lib/install/templates/default-domain.xml.template

replace 

<?xml version="1.0" encoding="UTF-8" ?>

with

<?xml version="1.0" encoding="UTF-8" ?>
<!DOCTYPE domain PUBLIC "-//Sun Microsystems Inc.//DTD Application Server 9.1
Domain//EN" "http://www.sun.com/appserver/dtds/sun-domain_1_3.dtd">


at the top for the file.
Comment 4 Vince Kraemer 2006-12-05 18:50:17 UTC
*** Issue 90604 has been marked as a duplicate of this issue. ***
Comment 5 Vince Kraemer 2006-12-05 19:01:44 UTC
http://serverplugins.netbeans.org/servlets/ReadMsg?list=cvs&msgNo=2278 addresses
this issue, too.
Comment 7 judytang 2006-12-06 22:31:41 UTC
I have used 12/5/06 6.0 NB daily build and tested with AS 9.1 PE/EE, GF V2 PE/EE
on build 26, and I can register all the servers fine without apply any
workaround. I am marking this bug as verified on 6.0 NB trunk.
Comment 8 Vince Kraemer 2006-12-08 00:47:17 UTC
*** Issue 90798 has been marked as a duplicate of this issue. ***
Comment 9 Sherold Dev 2006-12-12 11:06:16 UTC
The fix itself seems to be OK, although I miss the 'NOI18N' comments.

Here are a few comments to the relevant code, which do not directly relate to
this patch.

The FileInputStream should be wrapped into a BufferedInputStream. If the
domain.xml file is not parsable a RuntimeException will be thrown, this should
be caught. ErrorManager/Logger should be used instead of
Exception.printStackTrace() statements.
Comment 10 Vince Kraemer 2006-12-14 06:07:14 UTC
integrate to release551

Checking in
appsrvbridge/src/org/netbeans/modules/j2ee/sun/bridge/AppServerBridge.java;
/cvs/serverplugins/sun/appsrvbridge/src/org/netbeans/modules/j2ee/sun/bridge/AppServerBridge.java,v
 <--  AppServerBridge.java
new revision: 1.2.14.2.2.5.14.1; previous revision: 1.2.14.2.2.5
done
Checking in
appsrv81/src/org/netbeans/modules/j2ee/sun/ide/j2ee/ui/AddDomainPlatformPanel.java;
/cvs/serverplugins/sun/appsrv81/src/org/netbeans/modules/j2ee/sun/ide/j2ee/ui/AddDomainPlatformPanel.java,v
 <--  AddDomainPlatformPanel.java
new revision: 1.1.2.3.2.5.18.1; previous revision: 1.1.2.3.2.5
Comment 11 Jan Chalupa 2007-02-08 22:33:01 UTC
I thought we were going to publish the fix as a patch for NB 5.5, weren't we? 
Could we still do it? Petr G.?
Comment 12 pgebauer 2007-02-10 15:16:40 UTC
The issue has been fixed in the release55_fixes branch.

Checking in
appsrvbridge/src/org/netbeans/modules/j2ee/sun/bridge/AppServerBridge.java;
/cvs/serverplugins/sun/appsrvbridge/src/org/netbeans/modules/j2ee/sun/bridge/AppServerBridge.java,v
 <--  AppServerBridge.java
new revision: 1.2.14.2.2.5.8.1; previous revision: 1.2.14.2.2.5
done
Checking in
appsrv81/src/org/netbeans/modules/j2ee/sun/ide/j2ee/ui/AddDomainPlatformPanel.java;
/cvs/serverplugins/sun/appsrv81/src/org/netbeans/modules/j2ee/sun/ide/j2ee/ui/AddDomainPlatformPanel.java,v
 <--  AddDomainPlatformPanel.java
new revision: 1.1.2.3.2.5.14.1; previous revision: 1.1.2.3.2.5
done


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo