Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 90174 - Missing DTD node actions
Missing DTD node actions
Status: VERIFIED FIXED
Product: xml
Classification: Unclassified
Component: Code
6.x
All All
: P2 with 4 votes (vote)
: 6.x
Assigned To: Sonali Kochar
issues@xml
: REGRESSION
: 58967 79619 109145 121972 123774 (view as bug list)
Depends on: 127330
Blocks: 92999 130372
  Show dependency treegraph
 
Reported: 2006-11-28 13:06 UTC by Martin Schovanek
Modified: 2008-03-25 18:00 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Schovanek 2006-11-28 13:06:26 UTC
[#Dev 061127, jdk1.5.0]

to reproduce:
-------------
1) right click a .dtd node

ERROR: There is missing following actions:
- Generate CSS
- Check DTD
- Generate Documentation
- Generate DOM Tree Scanner
- SAX Document Handler Wizard
Comment 1 Jiri Skrivanek 2007-01-11 15:04:11 UTC
Still missing the following action in build 20070111-0831:

- Generate DOM Tree Scanner
- SAX Document Handler Wizard
Comment 2 Samaresh Panda 2007-03-31 18:17:22 UTC
Hi Marek, about the missing actions, is it something not intended for 6.0? Or
this is indeed a bug?
Comment 3 Marek Fukala 2007-04-02 10:59:57 UTC
Stepan Herold worked on this recently...
Comment 4 Samaresh Panda 2007-04-08 23:29:49 UTC
Stephen, any updates?
Comment 5 Sherold Dev 2007-04-30 14:40:39 UTC
Marek, it looks like you have temporarily commented out these actions in the
module layer file because of Retouche.
Comment 6 Samaresh Panda 2007-05-02 17:30:55 UTC
Marek, please take care of this or assign to the right person.
Comment 7 Marek Fukala 2007-05-03 10:01:32 UTC
You need to migrate the actions from the old java infrastructure to the
Retouche. There are some FAQs about how to do that:

http://wiki.netbeans.org/wiki/view/Java_DevelopersGuide
http://wiki.netbeans.org/wiki/view/RetoucheDeveloperFAQ
Comment 8 Samaresh Panda 2007-07-17 22:44:24 UTC
This is not enough. I have absolutely no idea what these actions used to do. If you want me to do it, you must also give
me the spec to read and understand these features.
Comment 9 Marek Fukala 2007-07-23 11:04:30 UTC
I am sorry, I am not aware of any spec for these actions (I din't create them, I was just maintaining). Maybe there are
some mentions of it in the help. I just remember that the actions generated java classes - sax parser handler and dom
tree scanner, based on the DTD structure. I belive that along with having netbeans 5.5 where you can easily check the
functionality this is enoght info. If not, I do not object against removing these features. I seriously doubt that there
is more that just a few users of it.
Comment 10 tonybeckham 2007-07-31 17:49:17 UTC
I think we should keep these two actions (Generate DOM Tree Scanner, SAX Document Handler Wizard)  I'm not sure how much
they are used but they seem like they would be useful, plus there are references to them in the help so if we are to get
rid of them we need to edit the help accordingly.
Comment 11 Samaresh Panda 2007-10-01 03:11:53 UTC
*** Issue 58967 has been marked as a duplicate of this issue. ***
Comment 12 Samaresh Panda 2007-10-01 03:19:40 UTC
*** Issue 79619 has been marked as a duplicate of this issue. ***
Comment 13 Samaresh Panda 2007-10-01 03:34:07 UTC
*** Issue 109145 has been marked as a duplicate of this issue. ***
Comment 14 Samaresh Panda 2007-11-16 21:47:10 UTC
*** Issue 121972 has been marked as a duplicate of this issue. ***
Comment 15 samlalani 2007-12-05 00:04:36 UTC
I was using the feature "Generate DOM Tree Scanner" extensively in NetBeans 5.5 and I have to keep that version around
just for this feature.  Please advise on alternatives if it is not implemented in v6.0.

Thank you.
Comment 16 ekrebs007 2007-12-05 19:38:23 UTC
I used Generate DOM Tree Scanner extensively in 5.5. It is a useful tool and should be implemented in 6.0.
In order to continue using this feature I have to use 5.5 and then include the generated file into 6.0. If this 
feature is going away please advise on alternatives.
Comment 17 Samaresh Panda 2007-12-05 23:02:12 UTC
Sorry, we couldn't make this into 6.0, however, we're considering this as a candidate for 6.1. Hang in there, we'll keep
you posted.
Comment 18 lewkim 2007-12-11 13:04:44 UTC
Please make sure this does get added in 6.1.  I use this functionality a lot.  Thank you.
Comment 19 mightypeo 2008-01-04 22:05:48 UTC
*** Issue 123774 has been marked as a duplicate of this issue. ***
Comment 20 mightypeo 2008-01-04 22:07:22 UTC
Please make sure that the SAX Document Handler Wizard gets added. I use this feature extensively in prototyping. How
else am I gonna have the IDE generate a SAX parser for me ?
Comment 21 Sonali Kochar 2008-02-22 16:47:51 UTC
I have added the Generate DOM tree scanner action. Working on the second action.
Comment 22 Sonali Kochar 2008-02-28 13:13:22 UTC
Fixed.

changeset 0180ce1fdb08 in main
details: http://hg.netbeans.org/main?cmd=changeset;node=0180ce1fdb08
description:
	Fix for #90174 - Missing DTD node actions - added the second action
Comment 23 tonybeckham 2008-02-29 22:31:32 UTC
Fix Verified:

Product Version: NetBeans IDE Dev (Build 200802291203)
Java: 1.5.0_13; Java HotSpot(TM) Client VM 1.5.0_13-119
System: Mac OS X version 10.5.2 running on i386; MacRoman; en_US (nb)
Comment 24 Keiichi Oono 2008-03-25 10:28:18 UTC
I'm using 6.1 beta, but SAX document handler wizard does not work. It can be selected from context menu but failed with
error message "Action failed due to internal error!". Would you take a look issue #130372 and the functionality of "SAX
Document Handler Wizard" menu?

DOM tree scanner is generated with out any errors, and it works fine.
Comment 25 tonybeckham 2008-03-25 17:32:33 UTC
When I verified this I saw this error but only if empty was set as the handler for any element, changing all the empty
to ignore worked.  However, now I see that even doing this the error still comes.  I think this issue should be closed
and issue 130372 be taken up for this issue.
Comment 26 tonybeckham 2008-03-25 17:44:20 UTC
What type of project are you trying this in.  When I try a BPEL module I get the error, but in a java project I do not
when using the simpletest.dtd file.  Actually, for the java project scenario, the dtd has to be located in <default
package> to work, any other package returns same error.

A strange note, once task is completed in a java project, it can be completed anywhere, such as in a BPEL project, or
from the files view at any local location...
Comment 27 Samaresh Panda 2008-03-25 17:55:56 UTC
The actions have been re-introduced, in other words, this bug is fixed. There may be new bugs because we have re-written
these actions. So lets track issue 130372 for the new failure. I do not see a reason why we should reopen this one.
Comment 28 tonybeckham 2008-03-25 18:00:12 UTC
I Agree.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo