Bug 90009 - Deadlock when generating a file from template
Deadlock when generating a file from template
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Source
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Tomas Zezula
issues@java
: THREAD
: 90747 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-24 13:35 UTC by Andrei Badea
Modified: 2007-01-17 10:09 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump (17.85 KB, text/plain)
2006-11-24 13:35 UTC, Andrei Badea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Badea 2006-11-24 13:35:24 UTC
The generator for JPA entity classes needs to create classes from the default
template for Java classes. During a run of the generator I got the attached
deadlock.
Comment 1 Andrei Badea 2006-11-24 13:35:59 UTC
Created attachment 36266 [details]
Thread dump
Comment 2 Tomas Zezula 2006-11-24 15:00:08 UTC
Deadlock among DataLoaders and Javac's lock. Thread (tid=0xa2604800) holds
DataLoader's lock and requires the javac's lock. The JS-Thread holds javac and
tries to acquire the DataLoader's lock.
Comment 3 Tomas Zezula 2006-11-27 17:19:15 UTC
Checking in src/org/netbeans/modules/java/source/usages/RepositoryUpdater.java;
/cvs/java/source/src/org/netbeans/modules/java/source/usages/RepositoryUpdater.java,v
 <--  RepositoryUpdater.java
new revision: 1.14; previous revision: 1.13
done
Comment 4 Tomas Zezula 2006-12-08 10:52:46 UTC
*** Issue 90747 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo