Bug 88776 - Not stable dynamic attach with jdk 1.6
Not stable dynamic attach with jdk 1.6
Status: VERIFIED WONTFIX
Product: profiler
Classification: Unclassified
Component: Base
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Tomas Hurka
issues@profiler
: RELNOTE
: 119987 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-07 10:01 UTC by ehucka
Modified: 2007-10-25 08:32 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
error log (16.02 KB, text/plain)
2006-11-07 10:02 UTC, ehucka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ehucka 2006-11-07 10:01:21 UTC
profiler 061107

I tried to attach to an swing application several times and always it ends after
a few seconds of profiling by java error.

Both ide and application run on jdk 1.6. b104, linux i586.

Application's log:

#
# An unexpected error has been detected by Java Runtime Environment:
#
#  Internal Error (53484152454432554E54494D450E435050020F), pid=14600,
tid=3041770400
#
# Java VM: Java HotSpot(TM) Client VM (1.6.0-rc-b104 mixed mode, sharing)
# An error report file with more information is saved as hs_err_pid14600.log
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
#
Aborted
Comment 1 ehucka 2006-11-07 10:02:00 UTC
Created attachment 35832 [details]
error log
Comment 2 ehucka 2006-11-07 10:04:19 UTC
It was memory liveness profiling, including allocation stacktraces.
Comment 3 ehucka 2006-11-07 10:20:15 UTC
When I tried CPU profiling, all classes it always crashes during
instrumentation. The application's log shows there are about 1800 classes redefined.
Comment 4 Tomas Hurka 2006-11-20 11:24:26 UTC
This looks to me like JDK bug. I will investigate.
Comment 5 ehucka 2006-11-29 11:26:28 UTC
I do not know if it is the same issue - always after detach with terminate
application from dynamically attached j2se application (AnagramGame) profiled
with jdk 1.6 (memory liveness profiling) a java error occurs:

#
# An unexpected error has been detected by Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x01010101, pid=4467, tid=3043269536
#
# Java VM: Java HotSpot(TM) Client VM (1.6.0-rc-b104 mixed mode, sharing)
# Problematic frame:
# C  0x01010101
#
Comment 6 Tomas Hurka 2006-11-29 18:01:59 UTC
This looks different to me. Please create new bug and attach VM crash dump.
Comment 7 Tomas Hurka 2006-11-29 18:17:41 UTC
Entered as JDK bug #6497639. http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6497639
Comment 8 ehucka 2006-11-30 16:47:36 UTC
verified
Comment 9 Tomas Hurka 2007-03-22 17:25:58 UTC
*** Issue 98673 has been marked as a duplicate of this issue. ***
Comment 10 Tomas Hurka 2007-03-27 17:49:12 UTC
*** Issue 98673 has been marked as a duplicate of this issue. ***
Comment 11 Tomas Hurka 2007-03-28 09:48:15 UTC
Running profiled application with -Xshare:off seems to work-around this issue.
Comment 12 J Bachorik 2007-10-25 08:32:35 UTC
*** Issue 119987 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo