Bug 119987 - [60cat] Profiler crashes target VM
[60cat] Profiler crashes target VM
Status: RESOLVED DUPLICATE of bug 88776
Product: profiler
Classification: Unclassified
Component: Base
6.x
PC Windows Vista
: P2 (vote)
: TBD
Assigned To: issues@profiler
issues@profiler
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-25 07:27 UTC by tboerkel
Modified: 2007-10-29 22:17 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Crash log (8.30 KB, text/plain)
2007-10-25 07:28 UTC, tboerkel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tboerkel 2007-10-25 07:27:33 UTC
[ BUILD # : 200710212201 ]
[ JDK VERSION : 1.6.0_03 ]

I am attaching the profiler to the target VM via local dynamic attach
(Java 6.0).

If I use Memory or CPU profiling, the target VM crashes shortly after
attach or a little while later.

This also happens with VisualVM. So, it is either a profiler issue or
a JDK issue.

Attaching crash log.

Output:
Profiler Agent: JNI On Load Initializing...
Profiler Agent: JNI OnLoad Initialized succesfully
Profiler Agent: Waiting for connection on port 5140 (Protocol
version: 8)
Profiler Agent: Established local connection with the tool
cache_loade_classes, classes 2
Retransform called
Retransform end
Profiler Agent: Redefining 100 classes at idx 0, out of total 513
Profiler Agent: Redefining 100 classes at idx 100, out of total 513
Profiler Agent: Redefining 100 classes at idx 200, out of total 513
Profiler Agent: Redefining 100 classes at idx 300, out of total 513
Profiler Agent: Redefining 100 classes at idx 400, out of total 513
Profiler Agent: Redefining 13 classes at idx 500, out of total 513
#
# An unexpected error has been detected by Java Runtime Environment:
#
#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x6d83de95,
pid=3380, tid=5868
#
# Java VM: Java HotSpot(TM) Client VM (1.6.0_03-b05 mixed mode,
sharing)
# Problematic frame:
# V  [jvm.dll+0x7de95]
#
# An error report file with more information is saved as
hs_err_pid3380.log
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
#
Comment 1 tboerkel 2007-10-25 07:28:11 UTC
Created attachment 51644 [details]
Crash log
Comment 2 J Bachorik 2007-10-25 08:32:41 UTC
this is a duplication of the issue #88776
a known workaround is to start the profiled application with -Xshare:off argument

*** This issue has been marked as a duplicate of 88776 ***
Comment 3 tboerkel 2007-10-25 09:12:37 UTC
Thanks, this works as workaround. However, CPU profiling does not work after attach. I get no live results and cannot
take snapshots. Not even for threads that are being started after attach. Is this a known problem? Shall I file a new issue?
Comment 4 Alexander Kouznetsov 2007-10-29 19:11:59 UTC
Try to:
1) Enable "Profile Threads started after entering any of root methods" Advanced Settings option
2) Open profiled application sources in NetBeans as project and select it in Attach dialog.

If this doesn't help then please file new issue.
Comment 5 tboerkel 2007-10-29 22:17:36 UTC
I did: Issue #120038. And it is already fixed. :-)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo