Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 8224 - USER TEST: Add a way to create a working directory from CVS wizard
USER TEST: Add a way to create a working directory from CVS wizard
Status: CLOSED INVALID
Product: ide
Classification: Unclassified
Component: UI
3.x
PC Windows 3.1/NT
: P4 (vote)
: TBD
Assigned To: Gabriel Tichy
issues@www
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-07 00:40 UTC by jhoffman
Modified: 2005-03-09 04:28 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
SelectDir (24.89 KB, image/jpeg)
2001-07-20 20:39 UTC, dmladek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jhoffman 2000-11-07 00:40:07 UTC
In our user testing, we discovered that four out of the five participants did
not create a working directory for their CVS files when working within the
mount CVS repository wizard.  There should be a mechanism to create a new
directory in the wizard, without relying on the Java File Chooser dialog's
meager support.  Perhaps a "Create" button next to the working directory
entry field.
Comment 1 dmladek 2000-11-07 09:35:59 UTC
Hi Jeffrey,
I don't understand what you exactly mean.
There is already a way how to create "New Folder" in CVS wizard.
USe the button "Browse" and in a Dialog "Select Dir" in its right top
there are a set of icons. One of them is for creating new dir.

Putting ather button "New" next to current one "Browse" IMHO is not clever
solution. HAve you thought about what dialog you expect to be popuped?
I've tried it, but I've got only one idea: You need exactly the same dialog
as it appears for "Browse", don't you?

Only thing wchich could be make better is the dialog where you choose or create
dir.
But it's not CVS bug/enhancement but enhancement/bug for J2SDK - > SWING ->
new JFileChooser or what it is exactly.
If could I ask you and you still think it needs some improval, please,
enter the bug into bugtraq for apropriate component. For me I will also
apreceate if there will be possibility to delete a dir.
thanks you

You can look at attached jpeg with the dialog Select Dir.
Comment 2 dmladek 2000-11-07 09:36:59 UTC
Created attachment 270 [details]
SelectDir
Comment 3 Jiri Kovalsky 2000-11-07 10:36:59 UTC
I agree with Dan that there is already a way that allows user to create new
directory in JFileChooser that frankly speaking isn't the best but exists. If
we add "New" button next to "Browse" what would follow ? You will have to enter
the name of new folder and choose where it will be placed and for this task you
will need JFileChooser to give user some comfort. So what is the difference
and/or benefit ?
Comment 4 jhoffman 2000-11-07 17:02:59 UTC
The issue is simply that users did not know how to create a working directory
from within the product.  Yes, the JFileChooser does provide a way to do this,
but it isn't clear from the wizard UI that the user can create a working
directory.  In our user test, all but one user just took the default, which is
*not* the desired interaction.

The purpose of this bug is to highlight the issue. It is not to jump to a
design conclusion. Consider the user test results when designing/redesigning
the CVS wizard.
Comment 5 dmladek 2000-11-08 09:20:59 UTC
Hi Jeffrey,
I've asked you if you could give us an idea of solving your suggestion.
IMHO having 2 buttons for 1 dialog isn't clever.
And IMHO that is design issue, I'm afraid that it isn't bug of cvs module.
This is task of UI team.
Thanks for comments
Comment 6 Chris Ledantec 2000-11-08 12:13:59 UTC
a couple of things that we need to consider here:

1. where the users really up to speed on cvs? from what i saw of the data the
knowledge of cvs was fairly basic. i didn't have the advantage of being able to
sit with any of the users during the test, but not understanding the importance
of a working dir is pretty poor knowledge. we can be responsible for teaching
cvs.

2. if it is the case that most users are picking a default then, once again, we
need to come up with a good sensible default. like with the default directory
for just about every other aspect of the ide we need to get away from
$netbeans_home and try to come up with a better offering. on unix we might do
something like create a nb_working dir in the home directory and on windows we
could create the same directory in the root folder of $netbeans_home (mabe
something like c:\ or c:\progra~1 or what not) my gut feeling is that this
could be tied to the project default dir but maybe not so closely since the a
project should be defined seperately than cvs contents.

3. if the jfilechooser is not doing the job addequately then we need to look
even more seriously at providing our own. i know creating a new directory is
common practice in windows the windows file choosers, and certainly resonble to
expect the same in current unix window managers (gnome, kde) so i think that
the user expectation exists but the current file chooser we are using is just
not effectively communicating that functionality.

i think the primary goal of cvs is to lay bare and coherent all of the
functionality of cvs in the gui. bcs of this we have to assume that the burden
of learning cvs is on the user not on the ide. that's not to justify bad
design, but i think stretching the design in superfluous directions should be
avoided. sure, we could add a button in the wizard that would allow the user to
create a new directory, but it would be duplicating standard functionality.
instead we should look at where that functionality is currently and try to fix
it there.
Comment 7 Quality Engineering 2003-07-01 15:16:07 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.
Comment 8 Quality Engineering 2003-07-01 15:19:29 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo