Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 81814 - Default value for "Debugger" field in the Attach Debugger dialog is unpredictable
Default value for "Debugger" field in the Attach Debugger dialog is unpredict...
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Code
5.x
All All
: P2 (vote)
: 5.x
Assigned To: Martin Entlicher
issues@debugger
SSBACKPORT SSX3 INMARS, release55_fix...
:
: 86965 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-03 15:11 UTC by Alexander Zgursky
Modified: 2007-02-19 11:49 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
The textual diff of the fix. (3.54 KB, text/plain)
2006-10-18 16:17 UTC, Martin Entlicher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Zgursky 2006-08-03 15:11:37 UTC
If there are more than one AttachType registered in the IDE the "Attach
Debugger..." dialog displays available Debuggers in the unpredictable order. The
order is always the same for the single IDE run, but if you close and run it
again - ther order may be different.
Because if that, the value selected in the "Debugger" combobox by default may
vary from one IDE start to another. I believe user would expect that the
"Debugger" field is filled by default with the last selected value.
Comment 1 Martin Entlicher 2006-08-07 13:52:02 UTC
They are obtained from the lookup, which uses hash maps and does not guarantee
any particular order.
We can e.g. sort them alphabetically to have consistent UI.
Comment 2 Martin Entlicher 2006-08-07 14:02:48 UTC
Fixed in trunk:

/cvs/debuggercore/src/org/netbeans/modules/debugger/ui/actions/ConnectorPanel.java,v
 <--  ConnectorPanel.java
new revision: 1.8; previous revision: 1.7
Comment 3 Alexander Zgursky 2006-08-07 14:25:04 UTC
OK, the consistent order is the one part of the issue. Another part is that the
user's choice is not remembered by the IDE. Should I post an enhancement on that?
Comment 4 Martin Entlicher 2006-08-07 15:55:26 UTC
Well, there is some commented relict of the code that stores the default value.
I'll find out why it was removed and if there's nothing wrong with it, I'll add
it back...
Comment 5 Martin Entlicher 2006-08-07 16:28:09 UTC
It was likely planned, but actually never implemented. I've made the storage of
the last value in debugger settings. I've just JPDA debugger here, so please
verify that it works as expected. Thanks.

/cvs/debuggercore/src/org/netbeans/modules/debugger/ui/actions/ConnectorPanel.java,v
 <--  ConnectorPanel.java
new revision: 1.9; previous revision: 1.8
Comment 6 Alexander Zgursky 2006-09-07 17:16:36 UTC
Is it possible to integrate a fix into release55 branch?
Comment 7 Martin Entlicher 2006-09-08 11:04:04 UTC
Well, it does not seem to be important enough, sorry.
The policy for fixes into 5.5 are:
* P1 regression over 5.0
* Blocker for Java EE 5 development
* Highly user voted bug whose fix does not require update to many NetBeans parts

This does not seem to be any of these.
Comment 8 Alexander Zgursky 2006-09-08 11:50:34 UTC
I see. OK then.
Comment 9 Martin Entlicher 2006-09-12 15:13:33 UTC
Thanks to Ivan, we discovered a bug in the fix, the compareTo() method must be
called with a String argument:

/cvs/debuggercore/src/org/netbeans/modules/debugger/ui/actions/ConnectorPanel.java,v
 <--  ConnectorPanel.java
new revision: 1.10; previous revision: 1.9
Comment 10 Alexander Zgursky 2006-10-16 08:19:04 UTC
*** Issue 86965 has been marked as a duplicate of this issue. ***
Comment 11 Martin Entlicher 2006-10-18 16:17:11 UTC
Created attachment 35338 [details]
The textual diff of the fix.
Comment 12 Martin Entlicher 2006-10-25 11:16:23 UTC
The fix of this issue is merged into release55_mars branch:

/shared/data/ccvs/repository/debuggercore/src/org/netbeans/modules/debugger/ui/actions/ConnectorPanel.java,v
 <--  ConnectorPanel.java
new revision: 1.5.8.1.2.1.18.1; previous revision: 1.5.8.1.2.1
Comment 13 Jiri Kovalsky 2006-11-10 14:52:36 UTC
This is very annoying issue. Please integrate the fix to release55_fixes branch
as well in order to get this to HotFixes AUC. Thank you.
Comment 14 Martin Entlicher 2006-11-13 15:09:31 UTC
The fix is merged into release55_fixes:
/shared/data/ccvs/repository/debuggercore/src/org/netbeans/modules/debugger/ui/actions/ConnectorPanel.java,v
 <--  ConnectorPanel.java
new revision: 1.5.8.1.2.1.20.1; previous revision: 1.5.8.1.2.1

And the module spec. version is increased:
/shared/data/ccvs/repository/debuggercore/manifest.mf,v  <--  manifest.mf
new revision: 1.71.10.1.2.3.4.1; previous revision: 1.71.10.1.2.3
Comment 15 Martin Entlicher 2006-11-20 11:31:19 UTC
The fix is merged into release551:

/shared/data/ccvs/repository/debuggercore/src/org/netbeans/modules/debugger/ui/actions/ConnectorPanel.java,v
 <--  ConnectorPanel.java
new revision: 1.5.8.1.2.1.22.1; previous revision: 1.5.8.1.2.1
Comment 16 Jiri Kovalsky 2006-12-08 14:44:50 UTC
The fix works like a charm in NetBeans 5.5 FCS patched by NBM file built from
sources checked out on December 01. Affected dialog always correctly remembers
last selected debugger provider. It's a Go from QA to have the NBM staged on 5.5
HotFix AUC.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo