Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 79905 - huge performance regression generating a web report
huge performance regression generating a web report
Status: RESOLVED DUPLICATE of bug 78312
Product: uml
Classification: Unclassified
Component: Reporting
5.x
Sun Solaris
: P1 (vote)
: 5.x
Assigned To: Yang Su
issues@uml
: REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-10 14:54 UTC by hajue
Modified: 2006-08-31 02:28 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hajue 2006-07-10 14:54:38 UTC
Generating a web report was a nice feature in NetBeans 5.5 preview. The 
reporting was done within few minutes. It was only a deficit that one could not 
zoom in (and out) the diagrams.

In NetBeans 5.5 beta the web report slows down to two diagrams per hour. It 
seems to me that the .jpg generation for the zooming functionality (5 jpg files 
per diagram) takes most of the time.

My UML project consists of 
- 13 class diagrams,
- 6 packages,
- 28 classes,
- 9 interfaces
- and some datatypes.
The web report doesn't succeded within 8 hours.
Comment 1 Sergey Petrov 2006-07-10 15:59:36 UTC
Hi hajue,
Can you specify the way you access your system(local/vnc/remote desktop)?
Comment 2 hajue 2006-07-10 16:20:14 UTC
Yes, well, we access the server via WRQ ReflectionX v11 and a 100 MBit/s LAN.
Comment 3 Sergey Petrov 2006-07-10 17:15:47 UTC
ok,
I thought it's in release notes, but i prefer to think it's a bug in any case,
let it be opened for now :) until release noted or fixed,
You can apply workaround for now:
go to <ide_installation_path>/etc/netbeans.conf and add
-J-Dsun.java2d.pmoffscreen=false
flag to netbeans_default_options. You'll get impovement in some uml actions but
it may result in less overal netbeans perfomance.

see also 78312, I don't like to close this one as duplicate for now becase I
think first one should have higher priory or at least be documented.
Comment 4 Sergey Petrov 2006-07-10 17:16:17 UTC
and see alse 78290
Comment 5 hajue 2006-07-11 09:55:17 UTC
Very well, with the given parameter the report generation lasts less than 7 
minutes now again (of which 4 minutes are needed for the JPG construction).
Comment 6 Trey Spiva 2006-07-26 18:59:36 UTC

*** This issue has been marked as a duplicate of 78312 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo