Bug 78312 - REMOTE_X: It takes 30 times longer to generate model reports on a remote desktop
REMOTE_X: It takes 30 times longer to generate model reports on a remote desktop
Status: VERIFIED FIXED
Product: uml
Classification: Unclassified
Component: Reporting
5.x
All Solaris
: P3 (vote)
: 6.x
Assigned To: issues@uml
issues@uml
COKE_REVIEWED, REMOTE_X, 55uml_beta_r...
: PERFORMANCE, RELNOTE
: 78290 79905 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-19 21:30 UTC by bugbridge
Modified: 2007-06-14 01:07 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugbridge 2006-06-19 21:30:07 UTC
Original status: 1-Dispatched; Suggested Status: NEW

These items should be added to the Keywords: PERFORMANCE REGRESSION

Original submitter: sergeyp

Description:
reproducible with build 060503_6 (not reproducible on build with perfomance
flag) - solaris/linux

1. create uml project
2. add 7 different diagrams with some elements
3. perfome report from local terminal
it takes about 1.5 minutes
4. perfome reprort from remote desctop (100Mb local lan, reflectionX)
it takes 43 minutes with a lot of network traffic

Comment:
Remote desktop is a low priority platform at this point in time.
Comment 1 Trey Spiva 2006-07-26 18:56:57 UTC
*** Issue 78290 has been marked as a duplicate of this issue. ***
Comment 2 Trey Spiva 2006-07-26 18:59:30 UTC
*** Issue 79905 has been marked as a duplicate of this issue. ***
Comment 3 Trey Spiva 2006-07-26 19:01:54 UTC
We are going to mark this issue as a P4.  The reason that we are going to change
the priority is 3 fold.

1) This is a JVM issue.  As such there is nothing that we can do about it.  Fix
the JVM, and you will fix this issue.
2) Remote component is not a supported platform.
3) The use of the flag should already be in the Beta release notes.
Comment 4 Sergey Petrov 2006-07-27 09:38:37 UTC
revert back to P3 because 
-I haven't answers for some questions yet
and
-the issue isn't in release notes yet.
-I don't see any limitation for descktop in release notes al
so
-It's good to add link to appropriate jvm issue here
Comment 5 Sergey Petrov 2006-11-02 09:31:49 UTC
added coco_stopper, issue should be at least in rn for coco
and it seems a lot of enterprise users may use remote desktop also.
Comment 6 Peter Lam 2007-04-27 23:52:10 UTC
Workaround:
    To enhance the performance, add the -J-Dsun.java2d.pmoffscreen=false
command-line switch to the netbeans_default_options statement in the
    nb5.5-installation-directory/etc/netbeans.conf file and then restart the
IDE. t the IDE. 
Comment 7 Peter Lam 2007-06-14 01:07:05 UTC
This is no longer an issue after fix to issue 82394 in NB 6.0.
Verified in build netbeans-hudson-trunk-674-full.zip (070613).
Comment 8 Peter Lam 2007-06-14 01:07:32 UTC
Verified in build netbeans-hudson-trunk-674-full.zip (070613).


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo