Bug 72911 - I18N - BPEL editor and non-Latin1 characters can't be input in some places
I18N - BPEL editor and non-Latin1 characters can't be input in some places
Status: CLOSED DUPLICATE of bug 81177
Product: soa
Classification: Unclassified
Component: BPEL
5.x
PC Linux
: P1 (vote)
: 5.x
Assigned To: Alexey Anjeleevich
issues@soa
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-22 08:23 UTC by kovica
Modified: 2006-08-31 15:18 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kovica 2006-02-22 08:23:07 UTC
I installed the NB 5.5 preview on Linux with java 1.5.0_06.

Steps:
- create an BPEL project
- drop a Class on the diagram
- double click the Class to enter it's name
- when we try to enter some non-Latin1 characters is seems like the Enter key
was pressed
Comment 1 Ken Frank 2006-03-02 16:39:59 UTC
Does this diagram use same ui or code as the one for uml ? There is related
iz bug 72910 on this problem in that, which is also a longstanding bug
in bugtraq on it.

ken.frank@sun.com
Comment 2 sunlit 2006-06-23 10:59:30 UTC
this seems to be related to the issue mentioned by Ken
(http://www.netbeans.org/issues/show_bug.cgi?id=72910), 
using build Coke milestone 14 I can see the problem in Windows also:
attempting to change name of a BPEL element in design view to mbyte (Ja
characters in Ja locale) brings no result - after pressing Enter the name
reverts to original ASCII name 
Comment 3 Michael Frisino 2006-07-16 21:30:15 UTC
FYI - this is verifiable.
Comment 4 Michael Frisino 2006-07-16 21:31:30 UTC
ignore last comment. I got zinged by issuezilla, thought I was working a
different issue.
Comment 5 Alexey Anjeleevich 2006-07-28 13:01:16 UTC
Bug description looks strange, because there is no Class element on BPEL
palette, and there is no such element in BPEL, but Class element there is in
UML. So first question: is this bug was found in BPEL designer and not in UML?
Second question: what does it mean "seems like the Enter key
was pressed" ? (screenshot is needed). 

So too fix this bug we need answers for questions above, more information and
two screenshots.

We need detailed step by step information how this bug can be reproduced and
_result_screenshot_ (please attach this screenshot to this issue). Please,
specify correctly which element you drop from palette.

For text rendering and editing we use standart SWING components, so possible
cause of this bug: JRE was installed without needed language-pack. To check this
please try to enter some non-Latin1 characters in netbeans dialog (e.g.
name of new project in "Create new Java Application" dialog), make screenshot 
and attach it to this issue, please. (this is second screenshot we need).

Thank you.
Comment 6 Alexey Anjeleevich 2006-07-28 13:03:49 UTC
Accidentally I've marked this bug as fixed.
Comment 7 Michael Frisino 2006-07-30 19:33:32 UTC
We are still waiting for clarification on this bug. Also, since it is i18n we
can waive it for now.
Comment 8 Ken Frank 2006-07-31 00:41:40 UTC
Am removing incomplete keyword as user sunlit (Sasha) saw that this problem
does exist.

Sasha,
can you attach a gif or two to this issue ?

ken.frank@sun.com
Comment 9 Ken Frank 2006-08-15 19:17:41 UTC
To developers - I've asked for gif and more clarification on this
to be added to this issue.

ken.frank@sun.com
Comment 10 Ken Frank 2006-08-15 19:57:22 UTC
can developer look at 81177 and see if this one is same ? We think
it is but since developer reopened this one, we want to be sure.

If it is, I will close this one as a dup of that one.
(also that one has a gif)

ken.frank@sun.com
Comment 11 Alexey Yarmolenko 2006-08-18 13:00:58 UTC
I tried to use russain names for BPEL elements and they works OK(screenshot 
attached)

I suppose, this issue was created by mistake.
Comment 12 Ken Frank 2006-08-18 16:01:04 UTC
As per conversation with Sasha, am closing this one as a duplicate
of 81177.

Note that when using non mbyte characters, like Russian,
the problem might not be seen; use Japanese or Chinese
characters.

ken.frank@sun.com

*** This issue has been marked as a duplicate of 81177 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo