Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 71904 - Debugging JUnit Tests in Free Form Projects
Debugging JUnit Tests in Free Form Projects
Status: RESOLVED DUPLICATE of bug 46886
Product: projects
Classification: Unclassified
Component: Ant Freeform
5.x
All Windows ME/2000
: P3 (vote)
: 5.x
Assigned To: Jan Lahoda
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-26 15:32 UTC by asleson
Modified: 2006-07-11 23:56 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description asleson 2006-01-26 15:32:59 UTC
NetBeans provides the ability to debug through JUnit tests, which is a huge
productivity tool for tracking down bugs.  Unfortunately this ability is only
available in "native" NetBeans projects.

Unless used in a tightly-controlled environment, most projects used by
developers will almost surely be free form projects.  It would be nice to be
able to debug through JUnit tests in free form projects.
Comment 1 Marian Petras 2006-07-10 09:56:53 UTC
The JUnit module does support displaying of test results in free-form projects
(see http://junit.netbeans.org/doc/binding-freeform-to-output.html).

Reassigned to module ant/freeform for further evaluation.
Comment 2 Jesse Glick 2006-07-11 23:56:48 UTC
It is possible, just not yet set up for you automatically.

If you get the Freeform Project Extras module from nbextras.org you can get
project templates that include test debug targets. See also

http://wiki.java.net/bin/view/Netbeans/FaqAntNbjpdaconnect
http://www.netbeans.org/kb/41/freeform-config.html#runsingle

*** This issue has been marked as a duplicate of 46886 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo