Bug 69355 - [50cat] Exception opening navigator window for Ant build file
[50cat] Exception opening navigator window for Ant build file
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Ant
5.x
PC Windows XP
: P3 (vote)
: 5.x
Assigned To: Jesse Glick
issues@projects
: RANDOM, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-25 17:28 UTC by misterm
Modified: 2005-12-06 02:32 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description misterm 2005-11-25 17:28:43 UTC
[ BUILD # : beta 2 ]
[ JDK VERSION : 1.4.2_xx ]

The following error was thrown while opening the navigator window with a build file selected:

java.lang.AssertionError: java.beans.PropertyVetoException: 
	at org.apache.tools.ant.module.nodes.AntNavigatorPanel$1Panel.requestFocusInWindow(AntNavigatorPanel.java:85)
	at org.netbeans.modules.navigator.NavigatorTC.requestFocusInWindow(NavigatorTC.java:195)
	at org.netbeans.core.windows.view.ui.AbstractModeContainer.focusSelectedTopComponent(AbstractModeContainer.java:164)
	at org.netbeans.core.windows.view.ModeView.focusSelectedTopComponent(ModeView.java:133)
	at org.netbeans.core.windows.view.ViewHierarchy.activateModeView(ViewHierarchy.java:363)
	at org.netbeans.core.windows.view.ViewHierarchy.activateMode(ViewHierarchy.java:357)
	at org.netbeans.core.windows.view.DefaultView.changeGUI(DefaultView.java:399)
	at org.netbeans.core.windows.ViewRequestor.dispatchRequest(ViewRequestor.java:238)
	at org.netbeans.core.windows.ViewRequestor.processRequest(ViewRequestor.java:214)
	at org.netbeans.core.windows.ViewRequestor.postRequest(ViewRequestor.java:152)
	at org.netbeans.core.windows.ViewRequestor.scheduleRequest(ViewRequestor.java:91)
	at org.netbeans.core.windows.Central.activateModeTopComponent(Central.java:1381)
	at org.netbeans.core.windows.WindowManagerImpl.topComponentRequestActive(WindowManagerImpl.java:1014)
	at org.openide.windows.TopComponent.requestActive(TopComponent.java:599)
	at org.netbeans.modules.navigator.ShowNavigatorAction.performAction(ShowNavigatorAction.java:29)
	at org.openide.util.actions.CallableSystemAction$1.run(CallableSystemAction.java:94)
	at org.netbeans.modules.openide.util.ActionsBridge.doPerformAction(ActionsBridge.java:47)
	at org.openide.util.actions.CallableSystemAction.actionPerformed(CallableSystemAction.java:90)
	at org.openide.windows.TopComponent.processKeyBinding(TopComponent.java:849)
	at javax.swing.JComponent.processKeyBindings(JComponent.java:2484)
	at javax.swing.JComponent.processKeyEvent(JComponent.java:2401)
	at java.awt.Component.processEvent(Component.java:4909)
	at java.awt.Container.processEvent(Container.java:1569)
	at java.awt.Component.dispatchEventImpl(Component.java:3615)
	at java.awt.Container.dispatchEventImpl(Container.java:1627)
	at java.awt.Component.dispatchEvent(Component.java:3477)
	at java.awt.KeyboardFocusManager.redispatchEvent(KeyboardFocusManager.java:1713)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(DefaultKeyboardFocusManager.java:627)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(DefaultKeyboardFocusManager.java:831)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(DefaultKeyboardFocusManager.java:741)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:592)
	at java.awt.Component.dispatchEventImpl(Component.java:3506)
	at java.awt.Container.dispatchEventImpl(Container.java:1627)
	at java.awt.Window.dispatchEventImpl(Window.java:1606)
	at java.awt.Component.dispatchEvent(Component.java:3477)
[catch] at java.awt.EventQueue.dispatchEvent(EventQueue.java:456)
	at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:145)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:137)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:100)
Caused by: java.beans.PropertyVetoException: 
	at org.openide.explorer.view.ListView$Listener.vetoableChange(ListView.java:1143)
	at org.openide.util.WeakListenerImpl$VetoableChange.vetoableChange(WeakListenerImpl.java:177)
	at java.beans.VetoableChangeSupport.fireVetoableChange(VetoableChangeSupport.java:300)
	at java.beans.VetoableChangeSupport.fireVetoableChange(VetoableChangeSupport.java:217)
	at org.openide.explorer.ExplorerManager$1AtomicSetSelectedNodes.checkArgumentIsValid(ExplorerManager.java:200)
	at org.openide.explorer.ExplorerManager$1AtomicSetSelectedNodes.run(ExplorerManager.java:246)
	at org.openide.util.Mutex.readAccess(Mutex.java:261)
	at org.openide.explorer.ExplorerManager.setSelectedNodes(ExplorerManager.java:253)
	at org.apache.tools.ant.module.nodes.AntNavigatorPanel$1Panel.requestFocusInWindow(AntNavigatorPanel.java:83)
	... 40 more
Comment 1 Jesse Glick 2005-12-05 23:33:44 UTC
I think it was a random race condition, in which case I can try to fix, but of
course I cannot verify.
Comment 2 Jesse Glick 2005-12-06 02:32:15 UTC
committed     Up-To-Date  1.3        
ant/src/org/apache/tools/ant/module/nodes/AntNavigatorPanel.java


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo