Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 69199 - [50cat] Improve keyboard navigation for "Change Method Parameters"
[50cat] Improve keyboard navigation for "Change Method Parameters"
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Refactoring
5.x
PC Windows XP
: P3 (vote)
: TBD
Assigned To: Ralph Ruijs
issues@java
:
: 126930 (view as bug list)
Depends on:
Blocks: 65780
  Show dependency treegraph
 
Reported: 2005-11-23 16:06 UTC by clever
Modified: 2011-05-25 11:23 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description clever 2005-11-23 16:06:55 UTC
[ BUILD # : 200511211900 ]
[ JDK VERSION : 1.4.2_xx ]

In general, the 'change method parameter' window has poor support for keyboard navigation. After changing a method name, I naturally hit TAB. Instead of being taken to the type field, the entire row is selected, leading me to run to the mouse for help.
Comment 1 Ralph Ruijs 2011-05-23 13:24:57 UTC
*** Bug 126930 has been marked as a duplicate of this bug. ***
Comment 2 Ralph Ruijs 2011-05-24 15:09:24 UTC
Changeset: 4712f15b81bb
Author:    Ralph Benjamin Ruijs <ralphbenjamin@netbeans.org>
Date:      2011-05-24 16:29
Message:   
Issue #69199 - [50cat] Improve keyboard navigation for "Change Method Parameters"
Comment 3 Quality Engineering 2011-05-25 11:23:27 UTC
Integrated into 'main-golden', will be available in build *201105250400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/4712f15b81bb
User: Ralph Benjamin Ruijs <ralphbenjamin@netbeans.org>
Log: Issue #69199 - [50cat] Improve keyboard navigation for "Change Method Parameters"


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo