Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 126930 - enable TAB navigation in "change method parameters"
enable TAB navigation in "change method parameters"
Status: RESOLVED DUPLICATE of bug 69199
Product: editor
Classification: Unclassified
Component: Refactoring
6.x
All Windows XP x64
: P3 (vote)
: TBD
Assigned To: Ralph Ruijs
issues@java
:
Depends on:
Blocks: 65780
  Show dependency treegraph
 
Reported: 2008-02-07 16:48 UTC by softwarevisualization
Modified: 2011-05-23 13:24 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description softwarevisualization 2008-02-07 16:48:34 UTC
The refactoring "Change Method Parameters" presents the user with a table (it appears)  of parameters and their properties. 

When the user is entering the properties, they are editing one (table) row. The normal behavior of the TAB key 
in this case is to move the point of editing over one cell (column) to the right. Currently hitting the TAB key 
does nothing. 

Users have been trained by long association to hit the TAB key when they want to move the editing point in an editable
table. It feels unnatural and even broken that this table does not respond in the expected way to TAB keys. 

thank you.
Comment 1 Ralph Ruijs 2011-05-23 13:24:57 UTC

*** This bug has been marked as a duplicate of bug 69199 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo