Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 66195 - AE from FreeformEvaluator.propertyChange
AE from FreeformEvaluator.propertyChange
Status: RESOLVED DUPLICATE of bug 128134
Product: projects
Classification: Unclassified
Component: Ant Freeform
5.x
All All
: P3 (vote)
: 6.x
Assigned To: Milan Kubec
issues@projects
: RANDOM
: 67878 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-07 02:28 UTC by sviyer
Modified: 2008-06-20 15:08 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sviyer 2005-10-07 02:28:00 UTC
I get a log of the following when editing an xml ant build file.

Where can I download daily buids for NB 5.0 ? I know where for NB4.1 but can't
find url for NB 5.0 daily buiilds.

Note that I am using NB 5.0 Beta.

----------------------------------------------------

[org.apache.tools.ant.module] *********** Exception occurred ************ at
2:21 PM on Oct 7, 2005
java.lang.NullPointerException
	at org.openide.nodes.Children$Keys.setKeys(Children.java:1971)
	at
org.apache.tools.ant.module.nodes.AntProjectChildren.refreshKeys(AntProjectChildren.java:78)
	at
org.apache.tools.ant.module.nodes.AntProjectChildren.stateChanged(AntProjectChildren.java:92)
[catch] at
org.apache.tools.ant.module.xml.AntProjectSupport$ChangeFirer.run(AntProjectSupport.java:384)
	at org.openide.util.Task.run(Task.java:207)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:469)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:870)
*********** Exception occurred ************ at 2:23 PM on Oct 7, 2005
java.lang.AssertionError: Got change from
org.netbeans.spi.project.support.ant.PropertyUtils$SequentialPropertyEvaluator@fdb413
rather than current delegate
org.netbeans.spi.project.support.ant.PropertyUtils$SequentialPropertyEvaluator@930574
	at
org.netbeans.modules.ant.freeform.FreeformEvaluator.propertyChange(FreeformEvaluator.java:168)
	at
org.netbeans.spi.project.support.ant.PropertyUtils$SequentialPropertyEvaluator.stateChanged(PropertyUtils.java:816)
	at org.openide.util.WeakListenerImpl$Change.stateChanged(WeakListenerImpl.java:278)
	at org.netbeans.spi.project.support.ant.PropertyUtils$3.run(PropertyUtils.java:266)
	at org.openide.util.Mutex.readAccess(Mutex.java:195)
	at org.netbeans.spi.project.support.ant.PropertyUtils$4.run(PropertyUtils.java:281)
	at org.openide.util.Task.run(Task.java:207)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:469)
[catch] at
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:870)
*********** Exception occurred ************ at 2:23 PM on Oct 7, 2005
java.lang.AssertionError: Got change from
org.netbeans.spi.project.support.ant.PropertyUtils$SequentialPropertyEvaluator@307c44
rather than current delegate
org.netbeans.spi.project.support.ant.PropertyUtils$SequentialPropertyEvaluator@109cbbe
	at
org.netbeans.modules.ant.freeform.FreeformEvaluator.propertyChange(FreeformEvaluator.java:168)
	at
org.netbeans.spi.project.support.ant.PropertyUtils$SequentialPropertyEvaluator.stateChanged(PropertyUtils.java:816)
	at org.openide.util.WeakListenerImpl$Change.stateChanged(WeakListenerImpl.java:278)
	at org.netbeans.spi.project.support.ant.PropertyUtils$3.run(PropertyUtils.java:266)
	at org.openide.util.Mutex.readAccess(Mutex.java:195)
	at org.netbeans.spi.project.support.ant.PropertyUtils$4.run(PropertyUtils.java:281)
	at org.openide.util.Task.run(Task.java:207)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:469)
[catch] at
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:870)
*********** Exception occurred ************ at 2:23 PM on Oct 7, 2005
java.lang.AssertionError: Got change from
org.netbeans.spi.project.support.ant.PropertyUtils$SequentialPropertyEvaluator@497536
rather than current delegate
org.netbeans.spi.project.support.ant.PropertyUtils$SequentialPropertyEvaluator@1deb89b
	at
org.netbeans.modules.ant.freeform.FreeformEvaluator.propertyChange(FreeformEvaluator.java:168)
	at
org.netbeans.spi.project.support.ant.PropertyUtils$SequentialPropertyEvaluator.stateChanged(PropertyUtils.java:816)
	at org.openide.util.WeakListenerImpl$Change.stateChanged(WeakListenerImpl.java:278)
	at org.netbeans.spi.project.support.ant.PropertyUtils$3.run(PropertyUtils.java:266)
	at org.openide.util.Mutex.readAccess(Mutex.java:195)
	at org.netbeans.spi.project.support.ant.PropertyUtils$4.run(PropertyUtils.java:281)
	at org.openide.util.Task.run(Task.java:207)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:469)
[catch] at
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:870)
*********** Exception occurred ************ at 2:23 PM on Oct 7, 2005
java.lang.AssertionError: Got change from
org.netbeans.spi.project.support.ant.PropertyUtils$SequentialPropertyEvaluator@b37089
rather than current delegate
org.netbeans.spi.project.support.ant.PropertyUtils$SequentialPropertyEvaluator@1f22e88
	at
org.netbeans.modules.ant.freeform.FreeformEvaluator.propertyChange(FreeformEvaluator.java:168)
	at
org.netbeans.spi.project.support.ant.PropertyUtils$SequentialPropertyEvaluator.stateChanged(PropertyUtils.java:816)
	at org.openide.util.WeakListenerImpl$Change.stateChanged(WeakListenerImpl.java:278)
	at org.netbeans.spi.project.support.ant.PropertyUtils$3.run(PropertyUtils.java:266)
	at org.openide.util.Mutex.readAccess(Mutex.java:195)
	at org.netbeans.spi.project.support.ant.PropertyUtils$4.run(PropertyUtils.java:281)
	at org.openide.util.Task.run(Task.java:207)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:469)
[catch] at
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:870)
*********** Exception occurred ************ at 2:23 PM on Oct 7, 2005
java.lang.AssertionError: Got change from
org.netbeans.spi.project.support.ant.PropertyUtils$SequentialPropertyEvaluator@df39bc
rather than current delegate
org.netbeans.spi.project.support.ant.PropertyUtils$SequentialPropertyEvaluator@1abf41f
	at
org.netbeans.modules.ant.freeform.FreeformEvaluator.propertyChange(FreeformEvaluator.java:168)
	at
org.netbeans.spi.project.support.ant.PropertyUtils$SequentialPropertyEvaluator.stateChanged(PropertyUtils.java:816)
	at org.openide.util.WeakListenerImpl$Change.stateChanged(WeakListenerImpl.java:278)
	at org.netbeans.spi.project.support.ant.PropertyUtils$3.run(PropertyUtils.java:266)
	at org.openide.util.Mutex.readAccess(Mutex.java:195)
	at org.netbeans.spi.project.support.ant.PropertyUtils$4.run(PropertyUtils.java:281)
	at org.openide.util.Task.run(Task.java:207)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:469)
[catch] at
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:870)
*********** Exception occurred ************ at 2:23 PM on Oct 7, 2005
java.lang.AssertionError: Got change from
org.netbeans.spi.project.support.ant.PropertyUtils$SequentialPropertyEvaluator@5f33b8
rather than current delegate
org.netbeans.spi.project.support.ant.PropertyUtils$SequentialPropertyEvaluator@1c96bfc
	at
org.netbeans.modules.ant.freeform.FreeformEvaluator.propertyChange(FreeformEvaluator.java:168)
	at
org.netbeans.spi.project.support.ant.PropertyUtils$SequentialPropertyEvaluator.stateChanged(PropertyUtils.java:816)
	at org.openide.util.WeakListenerImpl$Change.stateChanged(WeakListenerImpl.java:278)
	at org.netbeans.spi.project.support.ant.PropertyUtils$3.run(PropertyUtils.java:266)
	at org.openide.util.Mutex.readAccess(Mutex.java:195)
	at org.netbeans.spi.project.support.ant.PropertyUtils$4.run(PropertyUtils.java:281)
	at org.openide.util.Task.run(Task.java:207)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:469)
[catch] at
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:870)
*********** Exception occurred ************ at 2:23 PM on Oct 7, 2005
java.lang.AssertionError: Got change from
org.netbeans.spi.project.support.ant.PropertyUtils$SequentialPropertyEvaluator@d2fb67
rather than current delegate
org.netbeans.spi.project.support.ant.PropertyUtils$SequentialPropertyEvaluator@1bdb1e6
	at
org.netbeans.modules.ant.freeform.FreeformEvaluator.propertyChange(FreeformEvaluator.java:168)
	at
org.netbeans.spi.project.support.ant.PropertyUtils$SequentialPropertyEvaluator.stateChanged(PropertyUtils.java:816)
	at org.openide.util.WeakListenerImpl$Change.stateChanged(WeakListenerImpl.java:278)
	at org.netbeans.spi.project.support.ant.PropertyUtils$3.run(PropertyUtils.java:266)
	at org.openide.util.Mutex.readAccess(Mutex.java:195)
	at org.netbeans.spi.project.support.ant.PropertyUtils$4.run(PropertyUtils.java:281)
	at org.openide.util.Task.run(Task.java:207)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:469)
[catch] at
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:870)
*********** Exception occurred ************ at 2:23 PM on Oct 7, 2005
java.lang.AssertionError: Got change from
org.netbeans.spi.project.support.ant.PropertyUtils$SequentialPropertyEvaluator@52744
rather than current delegate
org.netbeans.spi.project.support.ant.PropertyUtils$SequentialPropertyEvaluator@92a0e1
	at
org.netbeans.modules.ant.freeform.FreeformEvaluator.propertyChange(FreeformEvaluator.java:168)
	at
org.netbeans.spi.project.support.ant.PropertyUtils$SequentialPropertyEvaluator.stateChanged(PropertyUtils.java:816)
	at org.openide.util.WeakListenerImpl$Change.stateChanged(WeakListenerImpl.java:278)
	at org.netbeans.spi.project.support.ant.PropertyUtils$3.run(PropertyUtils.java:266)
	at org.openide.util.Mutex.readAccess(Mutex.java:195)
	at org.netbeans.spi.project.support.ant.PropertyUtils$4.run(PropertyUtils.java:281)
	at org.openide.util.Task.run(Task.java:207)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:469)
[catch] at
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:870)
*********** Exception occurred ************ at 2:23 PM on Oct 7, 2005
java.lang.AssertionError: Got change from
org.netbeans.spi.project.support.ant.PropertyUtils$SequentialPropertyEvaluator@108f060
rather than current delegate
org.netbeans.spi.project.support.ant.PropertyUtils$SequentialPropertyEvaluator@c7bb40
	at
org.netbeans.modules.ant.freeform.FreeformEvaluator.propertyChange(FreeformEvaluator.java:168)
	at
org.netbeans.spi.project.support.ant.PropertyUtils$SequentialPropertyEvaluator.stateChanged(PropertyUtils.java:816)
	at org.openide.util.WeakListenerImpl$Change.stateChanged(WeakListenerImpl.java:278)
	at org.netbeans.spi.project.support.ant.PropertyUtils$3.run(PropertyUtils.java:266)
	at org.openide.util.Mutex.readAccess(Mutex.java:195)
	at org.netbeans.spi.project.support.ant.PropertyUtils$4.run(PropertyUtils.java:281)
	at org.openide.util.Task.run(Task.java:207)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:469)
[catch] at
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:870)
*********** Exception occurred ************ at 2:23 PM on Oct 7, 2005
java.lang.AssertionError: Got change from
org.netbeans.spi.project.support.ant.PropertyUtils$SequentialPropertyEvaluator@a92aaa
rather than current delegate
org.netbeans.spi.project.support.ant.PropertyUtils$SequentialPropertyEvaluator@118e555
	at
org.netbeans.modules.ant.freeform.FreeformEvaluator.propertyChange(FreeformEvaluator.java:168)
	at
org.netbeans.spi.project.support.ant.PropertyUtils$SequentialPropertyEvaluator.stateChanged(PropertyUtils.java:816)
	at org.openide.util.WeakListenerImpl$Change.stateChanged(WeakListenerImpl.java:278)
	at org.netbeans.spi.project.support.ant.PropertyUtils$3.run(PropertyUtils.java:266)
	at org.openide.util.Mutex.readAccess(Mutex.java:195)
	at org.netbeans.spi.project.support.ant.PropertyUtils$4.run(PropertyUtils.java:281)
	at org.openide.util.Task.run(Task.java:207)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:469)
[catch] at
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:870)
Comment 1 sviyer 2005-10-07 02:50:27 UTC
every time I save the file I get a whole lot of assertion error in the log file
Comment 2 Jan Lahoda 2005-10-07 10:54:30 UTC
What kind of project do you use (standard J2SE project, freeform project, etc.)?
Comment 3 Jan Lahoda 2005-11-24 09:27:32 UTC
*** Issue 67878 has been marked as a duplicate of this issue. ***
Comment 4 Milos Kleint 2007-08-02 10:03:23 UTC
either ant/project or ant/freeform related only, not general projects issue.
Comment 5 Jesse Glick 2007-08-02 21:09:06 UTC
NPE is issue #65235, long since fixed, and unrelated to the AE's. Reporter: next time please file distinct exceptions
separately, as it is easier to track that way.
Comment 6 Milan Kubec 2007-09-17 15:39:54 UTC
I did some editing of build.xml but I'm not able to reproduce this problem, since it was reported long time ago and it's
probably related to different NPE that was already fixed, I'm closing this issue as worksforme. If you can still
reproduce, please provide steps how and reopen. Thanks.
Comment 7 Jesse Glick 2007-09-17 16:55:10 UTC
The AE is probably a race condition somewhere that I would not expect to be able to reproduce. I don't think it is
related to the NPE since the AE, but not the NPE, is found in issue #67878.
Comment 8 Jesse Glick 2007-09-17 16:57:13 UTC
Generally I think it is not OK to close bugs from assertions without making some change:

- fixing an actual problem

- improving the assertion message to include more information so you could get further the next time

- commenting out the assertion message, or changing to a logged warning, if the condition seems harmless
Comment 9 Lukas Hasik 2008-04-10 21:24:27 UTC
moving opened issues from TM <= 6.1 to TM=Dev
Comment 10 Milan Kubec 2008-06-20 15:08:42 UTC
Making it duplicate of issue with more up to date stack trace.

*** This issue has been marked as a duplicate of 128134 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo