Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 65764 - [65cat][50cat] Would be nice to add commit / rollback buttons in toolbar of the SQL Editon
[65cat][50cat] Would be nice to add commit / rollback buttons in toolbar of t...
Status: RESOLVED DUPLICATE of bug 31149
Product: db
Classification: Unclassified
Component: Code
5.x
PC Windows XP
: P2 with 3 votes (vote)
: TBD
Assigned To: Jiri Rechtacek
issues@db
:
Depends on: 31149 152412
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-03 21:45 UTC by vbrabant
Modified: 2011-10-23 20:21 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vbrabant 2005-10-03 21:45:30 UTC
[ BUILD # : Beta ]
[ JDK VERSION : 1.5.0_05 ]

[I am using the Derby Engine.]

When you are in the SQL Editor, would be nice to have a Commit/Rollback options.

Seems that it's always COMMIT by default. After each modification.
Comment 1 Andrei Badea 2005-10-04 10:06:56 UTC
Yeah, the connection has autoCommit set to true. And what's worse, the
connection is shared among the database explorer and the SQL editor, so I can't
set it to false while executing SQL statements, as it would interfere with
actions in the database explorer. Either disable the database explorer while
executing SQL statements, or change the architecture to enable multiple connections.
Comment 2 Michel Graciano 2008-11-03 12:46:31 UTC
IMO, if you support at least this feature per connection (even shared), it will help us a lot. Please, consider it for
next release.
Comment 3 David Vancouvering 2008-11-03 17:07:05 UTC
I recognize the value of this feature, but it requires some serious thought and probably rework of our architecture.  I
just don't know if we can commit to getting to it.  But your vote has impact, it definitely raises the priority, so
thank you.   I'll put it high on our "we should really do this" list.
Comment 4 David Vancouvering 2008-11-03 17:10:10 UTC
I don't think we can do it without using a connection pool because otherwise we will cause a regression in the uses of
the Database Explorer API.

Basically what we need is to add a connection pool to each DatabaseConnection, and then add a new method called
getJDBCConnectionFromPool().  The existing getJDBCConnection() would behave as before, working with a single shared
connection, but new users of the DB Explorer should use getJDBCConnectionFromPool(), and existing users (like the SQL
editor) can be rewritten to use this and thus allow per-session settings like Autocommit.

Comment 5 Jiri Rechtacek 2009-10-16 14:03:04 UTC
Reassigned to new owner.
Comment 6 matthias42 2011-10-23 20:21:44 UTC

*** This bug has been marked as a duplicate of bug 31149 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo