Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 152412 - Specific connection for each open editor
Specific connection for each open editor
Status: RESOLVED DUPLICATE of bug 31149
Product: db
Classification: Unclassified
Component: SQL Editor
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@db
:
Depends on:
Blocks: 65764
  Show dependency treegraph
 
Reported: 2008-11-05 11:43 UTC by sansan
Modified: 2012-04-17 19:03 UTC (History)
1 user (show)

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sansan 2008-11-05 11:43:02 UTC
To make transaction handling possible (work with auto-commit = off) i think it was a simple solution
to give each open sql editor his own database connection.
Other views (db explorer) can share one db connection to retrieve database metadata and so on.

An option is to make this configurable by user. By default each editor will use it's own database connection to keep 
the transactions apart. The user can control this behavior through an option in db-settings panel.

To work with auto-commit off, buttons at the sql editor toolbar are needed (commit/rollback)
Comment 1 David Vancouvering 2008-11-05 21:32:08 UTC
This is more of an internal implementation decision how we do this.  I think what you're asking for is that ability to
set autocommit separately for each open editor.  So, I think this issue is actually a task for implementing issue 65764.
Comment 2 Jiri Rechtacek 2009-10-16 14:06:35 UTC
Reassigned to new owner.
Comment 3 matthias42 2012-04-17 19:03:26 UTC
The interpretation from comment #2 sound sane - so this is a duplicate of bug # 31149.

*** This bug has been marked as a duplicate of bug 31149 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo