Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 63542 - losing keyboard focus when switching editors
losing keyboard focus when switching editors
Status: RESOLVED DUPLICATE of bug 60235
Product: ide
Classification: Unclassified
Component: Code
5.x
Macintosh Mac OS X
: P3 (vote)
: TBD
Assigned To: issues@ide
issues@ide
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-01 18:13 UTC by frankmccabe
Modified: 2005-09-13 13:58 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description frankmccabe 2005-09-01 18:13:44 UTC
Often, but not *every time* when switching between editors of different java files in the IDE the keyboard 
focus is lost. The mouse works (I can make selections etc) but the editor is unresponsive to the keyboard. 

However, when I bring up a modal dialog (it doesn't seem to matter which one, I usually use the open file 
dialog), cancel that dialog, keyboard focus is magically restored to the editor.

This is an issue both with 4.1 and with the current versions of 4.2. It happens often enough to be seriously 
annoying.
Comment 1 wjbug 2005-09-09 18:06:42 UTC
I have this same problem - the content of the editor window(s) (Java Editor is
the only thing I've checked), becomes uneditable via the keyboard.

The 'cut' & 'paste' toolbar icons are also dimmed and not selectable.  Keyboard
shortcuts also don't work.  If there are outstanding edits, the file can still
be saved, but you must mouse to the 'Save' command in the 'File.'

I haven't tested whether opening & closing a JDialog can fix the problem, as
documented in this initial posting of this issue.  I'll try that next time.

As mentioned in the original post, it is somewhat difficult to anticipate what
actually "triggers" this eroneous behavior.

Here's my system info:
uname -a
Darwin bb-pbook.ducom.edu 8.2.0 Darwin Kernel Version 8.2.0: Fri Jun 24 17:46:54
PDT 2005; root:xnu-792.2.4.obj~3/RELEASE_PPC Power Macintosh powerpc

java -version
java version "1.5.0_02"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_02-56)
Java HotSpot(TM) Client VM (build 1.5.0_02-36, mixed mode, sharing)

As you can see, I'm using the still experimental (non end-user release) of
Apple's Hotspot JVM v1.5.0_02.  This same issue also comes us when I use the
older, regular Apple JVM v1.4.2_08.

There are no Exceptions being reported and nothing logged to messages.log, when
this happens.  Let me know whether you'd like to see my messages.log anyway, if
there are module dependencies you'd like to check out.

Cheers,
Bill Bug
Comment 2 Roman Strobl 2005-09-13 13:58:58 UTC
Seems to be a duplicate of issue 60235.

*** This issue has been marked as a duplicate of 60235 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo