Bug 49026 - Permit user to specify ignore list for javac
Permit user to specify ignore list for javac
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Classpath
4.x
All All
: P1 with 5 votes (vote)
: 6.x
Assigned To: Jesse Glick
issues@java
http://wiki.netbeans.org/wiki/view/Ex...
plan60 nbide
: API, UI
: 42884 51097 61425 65510 82354 89706 91254 105197 (view as bug list)
Depends on: 97304 97351 99588 111681 118867 170231 196789 51151 91733 95974 95983 97053 97168 97215 97391 97474 98235 98573 98732 99399 99401 99804 101913 102035 102036 102468 115918 158105 168906
Blocks: 41537 98266
  Show dependency treegraph
 
Reported: 2004-09-14 18:41 UTC by kjmcdonald
Modified: 2011-03-17 15:04 UTC (History)
7 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Diff of changes (100.40 KB, application/x-gzip)
2007-03-02 03:34 UTC, Jesse Glick
Details
Commit log (29.93 KB, text/plain)
2007-03-02 03:35 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kjmcdonald 2004-09-14 18:41:56 UTC
I just recently re-organized my .java fiels so I
could use the 'java with existing sources' project
type.

In the past I have ended up with copies of some
files with other names, either to save a backup
before making a drastic change, or because of how
Windows 'work offline' works when both copies have
changed.

I now find I'm having lots of problems trying to
build and run my project, because by default NB is
trying to compile *every* .java file under the
'source packages' branch of the project tree.
There are always going to be files there that I
can't delete, and won't compile for some reason or
another.

I looked for a property to say 'ignore this file'
but couldn't find it. Is it possible to add
something like this?

Or even better, let the Java dependencies compile
only what is needed by the project?
Comment 1 Jesse Glick 2004-09-14 18:56:15 UTC
You can press F9 on a particular file to let Java dependencies do
their work. Or you can override the compile target to exclude certain
things when building the whole project. Or name the files something
other name *.java.

The IDE cannot safely provide an ignore list for javac because it
cannot in fact guarantee that javac will honor it, due to automatic
compilation of dependencies.
Comment 2 kjmcdonald 2004-09-14 19:01:45 UTC
I understand that javac might still compile something on it's own.

I'm just looking for a way to tell NB (or ANT) not to pass javac every
file in the tree to begin with. If one of the files that is passed to
javac depends on the file that was ignored, then I don't mind javac
trying to compile it on it's own.

Renaming the files is not an option. I need to beable to double click
them and have NB open them in the editor, that means NB needs to
recognize their type. Once I do fix them, or want to use them again, I
don't want to have to rename them all over again. Changing thier type
is a kludge.
Comment 3 Jesse Glick 2004-09-14 19:03:42 UTC
Maybe. Not for 4.0.
Comment 4 Jesse Glick 2004-09-14 19:04:23 UTC
Again, this is just a matter of GUI; you can easily ignore these files
by editing build.xml.
Comment 5 Jesse Glick 2004-09-28 15:57:39 UTC
Related to issue #49371.
Comment 6 David Konecny 2004-11-03 13:27:51 UTC
Marking as API since this would require adding a property
corresponding to javac's "excludes" attribute.
Comment 7 David Konecny 2004-11-10 15:55:23 UTC
*** Issue 51080 has been marked as a duplicate of this issue. ***
Comment 8 Jesse Glick 2004-11-10 20:24:02 UTC
*** Issue 42884 has been marked as a duplicate of this issue. ***
Comment 9 Jesse Glick 2005-10-04 00:14:51 UTC
*** Issue 65510 has been marked as a duplicate of this issue. ***
Comment 10 artibee 2006-05-23 21:25:12 UTC
Feedback from person on the SDN site 2006-05-22 concerning
42884 (Allow to define in/exclude for compilation) [Dup of this issue]:

"I totally agree; a UI for in/excluding compilation is essential.
I spend hours looking through the help files and references only
to discover that it is not available."
Comment 11 Jesse Glick 2006-08-22 20:48:20 UTC
*** Issue 82354 has been marked as a duplicate of this issue. ***
Comment 12 Jesse Glick 2006-11-25 02:16:55 UTC
*** Issue 89706 has been marked as a duplicate of this issue. ***
Comment 13 Jesse Glick 2006-11-29 23:26:39 UTC
There is a somewhat old proposal here:

http://java.netbeans.org/Proposals/Project/sourcepath_excludes.html

Does not mention changes to GlobalPathRegistry which would probably be required
(see issue #49371 for some background).
Comment 14 Jesse Glick 2006-11-29 23:51:55 UTC
cvs rtag excludes_49026_base ant/project java_nowww_1; cvs rtag -b -r
excludes_49026_base excludes_49026 ant/project java
Comment 15 _ rkubacki 2006-12-01 12:31:03 UTC
Marking as performance related as the use case described here has obvious
performance impact.
Comment 16 Jesse Glick 2006-12-01 16:25:10 UTC
I don't think this issue itself has much to do with performance, though one of
its possible use cases is as a workaround for the separate performance issue #49371.
Comment 17 Jesse Glick 2006-12-07 00:27:39 UTC
Rebased to BLD200612061900.
Comment 18 Jesse Glick 2006-12-07 17:53:43 UTC
*** Issue 61425 has been marked as a duplicate of this issue. ***
Comment 19 Jesse Glick 2006-12-20 00:33:52 UTC
*** Issue 91254 has been marked as a duplicate of this issue. ***
Comment 20 Jesse Glick 2006-12-29 00:39:17 UTC
Rebasing to excludes_49026_base_2 and branching ant/freeform also:

cvs rtag excludes_49026_base_2 ant/{freeform,project} java_nowww_1; cvs rtag -b
-r excludes_49026_base_2 excludes_49026 ant/freeform; cvs up -j BLD200612061900
-j excludes_49026_base_2 ant/project java

Details: http://wiki.netbeans.org/wiki/view/Excludes49026
Comment 21 Jan Becicka 2007-02-15 17:52:48 UTC
Is this issue going to be implemented for M7?
Comment 22 Tomas Zezula 2007-02-15 17:54:36 UTC
Probably M8.
Comment 23 Jesse Glick 2007-03-02 03:34:44 UTC
Created attachment 39085 [details]
Diff of changes
Comment 24 Jesse Glick 2007-03-02 03:35:35 UTC
Created attachment 39086 [details]
Commit log
Comment 25 Jesse Glick 2007-03-02 03:36:24 UTC
Done. For any problems please open separate issues blocking this one.
Comment 26 Jesse Glick 2007-06-06 21:12:51 UTC
*** Issue 105197 has been marked as a duplicate of this issue. ***
Comment 27 Jesse Glick 2010-02-16 12:11:48 UTC
*** Bug 51097 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo