Bug 41252 - Process output should be shown distinctly
Process output should be shown distinctly
Status: RESOLVED WONTFIX
Product: projects
Classification: Unclassified
Component: Ant Project
4.x
All All
: P2 (vote)
: TBD
Assigned To: Jesse Glick
issues@projects
buildsys-e-cand
: I18N, PLAN, UI
: 42184 44723 47898 74772 140541 (view as bug list)
Depends on: 41351 42525
Blocks: 41535 42184 44713 83311
  Show dependency treegraph
 
Reported: 2004-03-24 09:55 UTC by Jan Lahoda
Modified: 2010-07-02 19:33 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Lahoda 2004-03-24 09:55:31 UTC
[custom trunk build with new Debugger API, JDK
1.4.2_03]

Steps to reproduce:
1. Create a project with a main Java class.
2. In the main method try to print something into
the System.err or System.out stream.
3. Start debugger (Run/Run Main Project in Debugger).
4. The main class is executed in the debugger, but
nothing appears in the "Process Output"
Comment 1 Jan Jancura 2004-03-24 10:19:52 UTC
This is not New debugger regression.
The output is stolen by New Build System.

What can we do with it?
Is it as designed?
Comment 2 Milan Kubec 2004-03-24 10:34:52 UTC
I see this as a major problem even for execution of basic java
project. Actuall program output is mixed with ant output and can be
very difficult to find what is the actuall output and what is ant message.
Comment 3 Jesse Glick 2004-03-25 14:40:25 UTC
This is as currently designed - process output is shown in the same
tab as the debugger is launched in.

I filed #41351 to make sure the now-useless Process Output tab is not
shown until this is fixed.

I would like to be able to improve this for D but I cannot commit to
it yet as the implementation may be difficult to get right when you
consider border cases and we have not yet evaluated what it might entail.
Comment 4 Jesse Glick 2004-04-29 19:30:12 UTC
Will try to do some things. For now, I am suppressing hyperlinking of
build.xml and build-impl.xml in most cases.
Comment 5 Jesse Glick 2004-04-30 00:40:56 UTC
Thinking about some kind of hack (just for D) whereby in e.g.
build-impl.xml you could place something like

<echo level="debug">***NB-PRETTY*** org.nb.foo.Bundle.BUILDING_JAR
${dist.jar}</echo>

and then add to .../src/org/nb/foo/Bundle.properties:

BUILDING_JAR=Building {0}...

where the format slot is filled in with the Ant property.

If the Ant output formatter encountered a debug-level message with the
magic token, it would print the requested message to the output
window, and then suppress any further messages at info level or below
for the duration of the current target (excluding subtargets via <ant>
or <antcall>, i.e. more or less lexical scope). Need to somehow deal
with suppressing the target name too.

The nice thing is that manually edited build scripts are left
untouched. Only the generated scripts would get prettified output.
Comment 6 Jesse Glick 2004-04-30 05:14:28 UTC
committed     Up-To-Date  1.8        
ant/src/org/apache/tools/ant/module/run/AntOutputParser.java
Comment 7 Jesse Glick 2004-06-11 01:45:23 UTC
*** Issue 44723 has been marked as a duplicate of this issue. ***
Comment 8 Jesse Glick 2004-06-12 02:46:27 UTC
Improved by #42525 but not fully fixed. Does at least suppress
exception messaging when you have a compilation error.
Comment 9 brassel 2004-08-24 21:29:15 UTC
After setting "Options > Ant Settings > Verbosity Level" to "Quiet",
application output via System.out it is not displayed at all. IMHO,
this behavior should be regarded as DEFECT rather than a missing
FEATURE. (However, output to System.err is displayed in nice red
implicating that "Quiet" is in 4.0 what "Error only" was in 3.6.)

Suppressing ant output by the above setting, but let application
output pass, would, at least halfway ;-), resolve the issue of
distinguishing ant output and application output as asked for by Issue
44723.
Comment 10 Jesse Glick 2004-08-24 23:52:46 UTC
AFAIK you can't adjust the logging level of process output. stdout ->
INFO, stderr -> WARN. So setting Verbosity to Quiet (= Warnings Only
in 3.6) would only useful when running projects if stdout is
unimportant compared to stderr (which could be the case for some
apps). Generally, Quiet is unlikely to be useful, and Verbose and
Debug are mainly for tracking down configuration problems.

BTW "brassel": adding a comment to an issue does not automatically add
you to the CC list, so you will never see replies unless you add yourself.
Comment 11 Jesse Glick 2004-08-30 16:58:24 UTC
*** Issue 47898 has been marked as a duplicate of this issue. ***
Comment 12 Jesse Glick 2004-12-02 20:59:51 UTC
Unlikely though possible for 4.1; expected to be nontrivial to
implement, esp. if must be consistent across several non-freeform
project types.
Comment 13 Jesse Glick 2004-12-02 21:04:20 UTC
*** Issue 42184 has been marked as a duplicate of this issue. ***
Comment 14 Jesse Glick 2008-02-20 23:32:07 UTC
*** Issue 74772 has been marked as a duplicate of this issue. ***
Comment 15 t_h 2008-09-24 10:07:23 UTC
*** Issue 140541 has been marked as a duplicate of this issue. ***
Comment 16 Jesse Glick 2010-07-02 19:33:55 UTC
When using Compile on Save there is minimal output besides the program's stdio; should suffice for most purposes.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo