Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 40428 - First line in statically included page is skipped during debugging
First line in statically included page is skipped during debugging
Status: VERIFIED DUPLICATE of bug 31118
Product: javaee
Classification: Unclassified
Component: Debugger
3.x
PC Windows XP
: P3 (vote)
: 6.x
Assigned To: Libor Kotouc
issues@javaee
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-24 16:52 UTC by L Martinek
Modified: 2005-01-18 09:43 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description L Martinek 2004-02-24 16:52:55 UTC
When you step over line with <%@include..>, you
jump to included page, but on second line. First
line is skipped. If you set breakpoint in first
line, debugger will stop on second line anyway.
Comment 1 Martin Grebac 2004-02-27 19:54:26 UTC
No time to 3.6
Comment 2 Martin Grebac 2004-07-26 08:58:04 UTC
It's not possible to fix this for D.
Comment 3 Libor Kotouc 2005-01-14 10:18:21 UTC
The cause is that step over really steps over the first line :) The
correct behavior is to step over the line with include directive and
not step into included JSP at all.
It will be solved in scope of the issue #31118.

*** This issue has been marked as a duplicate of 31118 ***
Comment 4 Jiri Skrivanek 2005-01-18 09:43:03 UTC
Verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo