Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 31118 - DEBUG: "step out", "step in", "step over" not as clear in JSP as in java code
DEBUG: "step out", "step in", "step over" not as clear in JSP as in java code
Status: RESOLVED WONTFIX
Product: javaee
Classification: Unclassified
Component: Debugger
4.x
All All
: P3 (vote)
: TBD
Assigned To: Martin Entlicher
issues@javaee
:
: 40428 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-16 18:50 UTC by Jason Rush
Modified: 2016-07-07 08:55 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Rush 2003-02-16 18:50:36 UTC
Description: 
When debugging java code, the functionality of stepping in, over and out is 
very straightforward.
When debugging a JSP, it is certainly not so.  
If I am debugging a JSP and I set a breakpoint at a line that includes another 
JSP, I think step in should go into that JSP, step over should continue on to 
the next line in the JSP that I am looking at.  If I'm in the included JSP, 
step out should take me back to the including JSP.
I understand that this might be very difficult to implement, if not impossible, 
but it would make a lot more sense.
Current behavior of "step out" on a typical JSP is that it reports "unavailable 
source file." at org.apache.jasper.servlet.JspServlet.service line 385

Evaluation: 
dfrach@netbeans.org 2000-11-20
I discussed about this bug with Jan Jancura (jj97931) (debugger core).
We agree, that the corection is difficult, but possible (about 14 days) and
that this not bug, but rfe.

A comment.
Comment 1 Jason Rush 2003-02-16 18:51:12 UTC
Transferred from BugTraq 4389763.
Comment 2 Ana.von Klopp 2003-08-27 23:58:23 UTC
Discussed this with Jeff Hoffman today. We think that the 
desirable behaviour here would be: 

Step into:
- If you are on a request dispatcher statement 
  <jsp:forward> or <jsp:include>, then this should
  cause the debugger to stop on the first line of 
  code in the included file

- If you are on a line that indicates a static include, 
  go to the first line in the included file

- If you are on a custom action, try to step into the
  relevant tag handler method. 

- If you are in a scriptlet or similar with a java method
  invocation on another object, same as a java class. 

If we can't implement the first two, it might be better
to disable the step into action? 

Step out: 

- If in a JSP that was dispatched to (included or 
forwarded) run to the end of the JSP and stop on the 
servlet or JSP that forwarded to it and stop on the next 
line of code in that file (or run to end if this object 
handled the incoming request.

- If in a JSP that was statically included (includes 
prelude or coda), go to the first line of code in the 
including file after the include statement. For a coda, 
this means to the same as for a dynamic include since there 
are no more lines in the JSP itself. 

- If you're in a tag handler or other java object invoked 
from a JSP, you should end up in the JSP. 

Step over should go to the next line in the current source, 
that one should be trivial with JSR-45. 

Comment 3 Martin Grebac 2004-03-02 16:07:47 UTC
Almost all of these work now. 

The only remaining problems are static includes - Step Over and Step
Out does not work as expected. Status is:
Step In - steps into include
Step Over - steps into include
Step Out - steps out of the whole jsp itself

This will need to be fixed by some hidden breakpoints, or some
advanced stepping filtering. Will see whether we'll have time to fix
these to promo-D.
Comment 4 Libor Kotouc 2005-01-14 10:18:20 UTC
*** Issue 40428 has been marked as a duplicate of this issue. ***
Comment 5 Jiri Skrivanek 2005-03-14 12:46:14 UTC
Previously targeted for 4.0, so hopefully will be fixed in 4.1.
Comment 6 Libor Kotouc 2005-03-14 13:07:23 UTC
Not as easy as it looks.
JSR-45 solved many things but on the other hand it cannot solve the remaining.
Generally, the problem is that the actins like step over/into are in fact
performed on Java source, not on JSP. JSR-45 then translates the Java lines into
JSP lines and we cannot easily decide whether to continue or not.

e.g., JSP parser should be involved in solving this issue. It will be done
hopefully in the next version.
Comment 7 Martin Balin 2016-07-07 08:55:21 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo