Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 39238 - Wrong TC width after restart
Wrong TC width after restart
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Window System
3.x
PC Windows ME/2000
: P2 (vote)
: 3.x
Assigned To: Milos Kleint
issues@platform
:
: 39470 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-26 18:07 UTC by Tim Lebedkov
Modified: 2008-12-22 23:47 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Screenshot before NB restart (143.44 KB, image/jpeg)
2004-01-26 18:08 UTC, Tim Lebedkov
Details
Screenshot after NB restart (98.35 KB, image/jpeg)
2004-01-26 18:09 UTC, Tim Lebedkov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Lebedkov 2004-01-26 18:07:10 UTC
Hi,

How to reproduce:
- with a clean user dir start NB and place 
  the file systems window and project window on the
  right side (see the first screenshot);
- restart NB
- the components are now more narrow
Comment 1 Tim Lebedkov 2004-01-26 18:08:10 UTC
Created attachment 13074 [details]
Screenshot before NB restart
Comment 2 Tim Lebedkov 2004-01-26 18:09:17 UTC
Created attachment 13075 [details]
Screenshot after NB restart
Comment 3 David Simonek 2004-02-02 18:18:01 UTC
*** Issue 39470 has been marked as a duplicate of this issue. ***
Comment 4 David Simonek 2004-02-02 18:18:35 UTC
similar 39238 contains exact reproduction case.
Comment 5 David Simonek 2004-02-03 13:19:05 UTC
Passing to Marek for further processing, issue may be connected with
serialization of dimensions. Marek, note that some reporters said that
main window must be maximized to see effect of this bug. See 39238.
Comment 6 _ tboudreau 2004-02-09 15:27:32 UTC
I have somewhat similar problems on OS-X - on restart, Explorer takes up 80% of the 
width of the desktop.

Possibly related to some recent change in the mode defs in core?  I notice Navigator has 
started appearing above the Editor again, which means something changed (why is[was?] 
the default row of everything "20"?  And whatever the final value is, it should be 
documented)
Comment 7 _ tboudreau 2004-02-09 15:30:30 UTC
Possibly related:  issue 37280

Comment 8 David Simonek 2004-02-09 16:22:23 UTC
Passing to Milos, please ask Peter for help if you need to.
Comment 9 Milos Kleint 2004-02-12 07:55:41 UTC
from the screenshot it appears that the window is maximized, 
I think fix for issue #37369 is responsible for this.
Comment 10 Milos Kleint 2004-02-13 10:00:58 UTC
fixed in trunk.

Checking in ViewEvent.java;
/cvs/core/windows/src/org/netbeans/core/windows/view/ViewEvent.java,v
 <--  ViewEvent.java
new revision: 1.3; previous revision: 1.2
done
Checking in DefaultView.java;
/cvs/core/windows/src/org/netbeans/core/windows/view/DefaultView.java,v
 <--  DefaultView.java
new revision: 1.18; previous revision: 1.17
Comment 11 Marian Mirilovic 2004-02-25 16:32:39 UTC
verified in [nb_dev](200402241900)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo