Bug 38059 - parsing error (except first IDE session)
parsing error (except first IDE session)
Status: VERIFIED DUPLICATE of bug 37994
Product: projects
Classification: Unclassified
Component: Ant
3.x
PC Linux
: P1 (vote)
: TBD
Assigned To: issues@projects
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-12 15:44 UTC by andrew
Modified: 2005-07-15 07:44 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
second session ide.log (15.56 KB, text/plain)
2003-12-12 15:48 UTC, andrew
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andrew 2003-12-12 15:44:34 UTC
Enviroment:
linux, j2se 1.4.2_02, 
NB build from _current_ dev. CVS trunk,
(ministatus is off see ide.log)

Steps:
- rebuild the IDE
- start the IDE
- expand some of Ant's build.xml file - all
  works fine
- restart the IDE
- try expand the same build.xml file

Result:
- file's icon in Explorer becames "with
  parsing error" (I think)
- node doesn't expand
- tooltip shows ClassCastException
- it is impossible to select Ant's target
  in context menu
- ide.log has CCE (will be attached just now)

Ant module is unusable - P1.

P.S. I don't think it is Ant module issue, but
it was discovered here.
Comment 1 andrew 2003-12-12 15:48:12 UTC
Created attachment 12554 [details]
second session ide.log
Comment 2 Jesse Glick 2003-12-12 16:08:36 UTC
I have seen the same parse exception - repeatedly on one day, not
again. I put a patch into xerces.jar to show what was going on, and of
course the exception has not happened to me again. Nor am I able now
to reproduce the exception, either in my usual user dir, nor in a
fresh one (using either the original or patched xerces.jar). If I knew
how to reproduce it reliably, it would probably be fixable.

*** This issue has been marked as a duplicate of 37994 ***
Comment 3 Marian Mirilovic 2005-07-15 07:44:24 UTC
closed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo