Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 37057 - [w2k LF] IAE when dragging prop sheet column
[w2k LF] IAE when dragging prop sheet column
Status: VERIFIED DUPLICATE of bug 36708
Product: platform
Classification: Unclassified
Component: Window System
3.x
PC All
: P3 (vote)
: 3.x
Assigned To: _ tboudreau
issues@platform
:
Depends on: 31896
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-05 16:17 UTC by David Simonek
Modified: 2008-12-22 18:04 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Simonek 2003-11-05 16:17:05 UTC
Steps:
1) Open prop sheet
2) Click and try to drag this small thin column
header of property table
3) IAE is thrown

java.lang.IllegalArgumentException: Reordering not
supported
	at
org.openide.explorer.propertysheet.SheetColumnModel.moveColumn(SheetColumnModel.java:135)
	at
javax.swing.plaf.basic.BasicTableHeaderUI$MouseInputHandler.setDraggedDistance(BasicTableHeaderUI.java:216)
	at
javax.swing.plaf.basic.BasicTableHeaderUI$MouseInputHandler.mouseDragged(BasicTableHeaderUI.java:195)
	at
java.awt.AWTEventMulticaster.mouseDragged(AWTEventMulticaster.java:261)
	at
java.awt.Component.processMouseMotionEvent(Component.java:5148)
	at
javax.swing.JComponent.processMouseMotionEvent(JComponent.java:2779)
	at
java.awt.Component.processEvent(Component.java:4901)
	at
java.awt.Container.processEvent(Container.java:1569)
	at
java.awt.Component.dispatchEventImpl(Component.java:3615)
	at
java.awt.Container.dispatchEventImpl(Container.java:1627)
	at
java.awt.Component.dispatchEvent(Component.java:3477)
	at
java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:3483)
	at
java.awt.LightweightDispatcher.processMouseEvent(Container.java:3215)
	at
java.awt.LightweightDispatcher.dispatchEvent(Container.java:3128)
	at
java.awt.Container.dispatchEventImpl(Container.java:1613)
	at
java.awt.Window.dispatchEventImpl(Window.java:1606)
	at
java.awt.Component.dispatchEvent(Component.java:3477)
[catch] at
java.awt.EventQueue.dispatchEvent(EventQueue.java:456)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:201)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
	at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:145)
	at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:137)
	at
java.awt.EventDispatchThread.run(EventDispatchThread.java:100)
Comment 1 _ tboudreau 2003-11-06 16:51:56 UTC
Known and already fixed on the property panel rewrite branch - the
headers will be hidden.  Metal had me fooled because it didn't show
any if a header title wasn't specified, but GTK & Windows classic do.
Comment 2 _ tboudreau 2003-11-15 16:47:07 UTC

*** This issue has been marked as a duplicate of 36708 ***
Comment 3 Marian Mirilovic 2004-03-16 09:05:33 UTC
verified duplicate,
by the way it's already fixed in incoming NB3.6


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo