Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 36781 - exception is thrown when pushing Add/Module... menu item
exception is thrown when pushing Add/Module... menu item
Status: CLOSED FIXED
Product: platform
Classification: Unclassified
Component: Outline&TreeTable
3.x
Sun All
: P3 (vote)
: TBD
Assigned To: _ tboudreau
issues@platform
: RELNOTE
: 38434 (view as bug list)
Depends on: 33281 38434
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-23 06:03 UTC by bnv
Modified: 2008-12-23 10:32 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
ide.log (1.96 KB, text/plain)
2003-10-23 06:26 UTC, bnv
Details
Debug log (4.97 KB, text/plain)
2004-01-21 14:32 UTC, mslama
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bnv 2003-10-23 06:03:30 UTC
Product Version:  Sun ONE Studio 5  Standard
Edition (Build 030904)
IDE Versioning:   IDE/1 spec=3.42.2 impl=030904
Operating System: SunOs version 5.8 running on sparc
Java:             1.4.1_05 

To reproduce:
- push "Tools->Options" from main menu
- right click on the System|Modules node
- wait for the popup
- push the Down arrow key

The Object Types node is selected instead of the
next menu item 

- push Add/Module... menu item

The exception comes out
Comment 1 bnv 2003-10-23 06:26:21 UTC
Created attachment 11943 [details]
ide.log
Comment 2 mslama 2004-01-21 13:37:27 UTC
The same in NB dev build. First problem is that focus is probably
stealed by TreeTableView after popup menu is displayed. The same on
other nodes in OptionsPanel. Further problems are consequence of this
I think. I will investigate what happens with focus.
Comment 3 mslama 2004-01-21 14:30:51 UTC
Evaluation: The same happens on current dev build (my fresh NB build
040121). Reason is that TreeTableView requests focus after popup menu
request ie. focus is transferred incorrectly back to Options dialog.
Assigning to explorer. I will attach log from dev build. I added log
message to java.awtComponent.requestFocusHelper.
Comment 4 mslama 2004-01-21 14:31:56 UTC
Tree table view has separate subcomponent.
Comment 5 mslama 2004-01-21 14:32:44 UTC
Created attachment 13001 [details]
Debug log
Comment 6 _ tboudreau 2004-01-22 13:44:14 UTC
Okay, I should be able to do *something* and backport it to
release35A.  Is there a date by which that should be completed?

Plan:
 - First do a hotfix which simply catches the exception

 - Try to figure out what's really wrong, and see if it's fixable 
   without high risk of introducing other bugs (most changes in TTV 
   are high-risk - we hope to rewrite it completely for promo-D).  
   If there is a fix that seems simple and safe, fix it for real, 
   if not, stay with the hotfix and really fix it when
   we rewrite TTV.

The core problem is that TTV has lots of problems, is extremely
complex and its codebase is quite fragile - fixing one problem often
creates two others.  If possible we would prefer to defer addressing
existing issues with TTV until resources are allocated to rewrite it
from scratch.
Comment 7 _ tboudreau 2004-02-02 12:16:03 UTC
As agreed, this will not be solved for for 3.6 - the risk of introducing new problems is 
too high.   Changing target milestone to Promotion D.

Note that the tree table view rewrite is already in progress, on which this issue 
depends.
Comment 8 _ tboudreau 2004-02-12 13:52:33 UTC
Adding Arrow waiver request keyword.
Comment 9 Patrick Keegan 2004-03-04 22:16:53 UTC
proposed relnote: In Options window, sometimes nodes in the Options
tree are selected when you are trying to choose an item in a node's
contextual menu.
Comment 10 _ tboudreau 2004-07-21 16:22:14 UTC
Downgrading to P3 - note that the way to reproduce this bug is to use
the mouse to invoke a menu and then the keyboard to select in the
menu.  Does not seem like P2 material.
Comment 11 _ tboudreau 2004-07-25 03:22:30 UTC
*** Issue 38434 has been marked as a duplicate of this issue. ***
Comment 12 _ tboudreau 2004-07-25 15:27:34 UTC
Fixed - the UI was written to call requestFocus() on both mouse pressed and mouse 
released, so bringing up the menu set focus away from the menu.  No reason for it.

Checking in src/org/openide/explorer/view/TreeTable.java;
/cvs/openide/src/org/openide/explorer/view/TreeTable.java,v  <--  TreeTable.java
new revision: 1.53; previous revision: 1.52
done
Checking in src/org/openide/explorer/view/TreeTableView.java;
/cvs/openide/src/org/openide/explorer/view/TreeTableView.java,v  <--  
TreeTableView.java
new revision: 1.64; previous revision: 1.63
done
Comment 13 Marian Mirilovic 2005-11-01 09:18:07 UTC
Functionality is changed for NB 5.0 - closed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo