Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 38434 - Bad node selected in Options window on mouse release
Bad node selected in Options window on mouse release
Status: VERIFIED DUPLICATE of bug 36781
Product: platform
Classification: Unclassified
Component: Outline&TreeTable
3.x
PC All
: P4 (vote)
: 4.x
Assigned To: _ tboudreau
issues@platform
:
Depends on:
Blocks: 33281 36781
  Show dependency treegraph
 
Reported: 2004-01-06 16:12 UTC by Lukas Hasik
Modified: 2008-12-22 22:47 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Hasik 2004-01-06 16:12:17 UTC
200401051900, jdk1.4.2

-open Options window
-click a node to expand/collapse (try node that
have lot of  children or some node at bottom of
the page - "Annotation Types") and hold the left
button 
-the node above which you release the button is
selected

-the right behavior should be the the
collapsed/expanded node stay selected
Comment 1 Jiri Rechtacek 2004-01-07 09:46:35 UTC
Options dialog is built on TTV => reassigned to tree table view.
Comment 2 _ tboudreau 2004-01-07 10:35:14 UTC
Annoying but pretty trivial.  Adding to TreeTableView rewrite task -
I'm not fixing any more small bugs in TTV.

When I've got a month with nothing to do except rewrite it from
scratch, this and about 50 other bugs will get fixed.  TTV currently
is poorly designed, not all scalable, and basically a giant throbbing
ball of hacks.  Adding more hacks is likely to cause as many bugs as
it fixes.
Comment 3 _ tboudreau 2004-07-25 03:22:31 UTC
Same root cause as 36781 - both mouse pressed and mouse released change the selectied 
node (also the cause of the property sheet flashing when you click a node in the options 
window).

*** This issue has been marked as a duplicate of 36781 ***
Comment 4 Lukas Hasik 2004-07-30 07:48:31 UTC
verified - duplicate


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo