Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 35787 - Postpone irreversible changes at the end wizard's sequence
Postpone irreversible changes at the end wizard's sequence
Status: VERIFIED WONTFIX
Product: platform
Classification: Unclassified
Component: Dialogs&Wizards
3.x
All All
: P4 (vote)
: 4.x
Assigned To: Jiri Rechtacek
issues@platform
projects, s1s
: API, UI
Depends on: 26552
Blocks: 15267
  Show dependency treegraph
 
Reported: 2003-08-26 15:43 UTC by Jiri Rechtacek
Modified: 2008-12-22 21:07 UTC (History)
1 user (show)

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Rechtacek 2003-08-26 15:43:05 UTC
The current API only allows to inform the user
when the target chooser panel is going away. It is
a solution, but some actions which are already
done are irreversible, like creation of
nonexistent folders. (from issue 15267, parts 1st,
2nd)
Postpone creating irreversible object (e.g.
harddrive, remote server) at the time when user
gone over wizard (i.e. Finish option).
Comment 1 Jiri Rechtacek 2004-04-14 09:36:59 UTC
I decrease the priority. There was only one known use-case (creating
new folders in TemplateWizard) where this task made a sense. Because
TemplateWizard has been broadly changed and an user has no use for
creating new folders, then this task is no urgent, needn't be fixed.
Comment 2 Jiri Rechtacek 2004-05-07 10:19:24 UTC
To be consistent with the last comment, I close as wontfix.
Comment 3 Marian Mirilovic 2005-12-20 16:04:37 UTC
This issue was solved long time ago. Because nobody has reopened it neither
added comments, we are verifying/closing it now. 
If you are still able to reproduce the problem, please reopen. 

Thanks in advance.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo