Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 26552 - Clean up Wizard API
Clean up Wizard API
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: Dialogs&Wizards
3.x
All All
: P2 (vote)
: TBD
Assigned To: Jiri Rechtacek
issues@platform
: API, UMBRELLA
Depends on:
Blocks: 34323 7706 11439 16619 20685 23116 27512 28629 30216 34043 35266 35787 36093 54905
  Show dependency treegraph
 
Reported: 2002-08-16 12:54 UTC by _ ttran
Modified: 2008-12-22 09:49 UTC (History)
2 users (show)

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ ttran 2002-08-16 12:54:29 UTC
the current Wizard API forces client code to use
JComponent.putClientProperty() to communicate its
requests to the wizard infrastructure.  This is
weird.  We should use regular java setters/getters
instead.

putClientProperty() must still work for backward
compat reasons.
Comment 1 Jiri Rechtacek 2002-09-06 14:07:37 UTC
Note: method WizardDescriptor.Panel.isValid() should be renamed; there
is a clash with JPanel.isValid().
Comment 2 Jiri Rechtacek 2003-01-21 16:14:07 UTC
Requirement (issue 30208): Specify order calling the API methods: i.e.
readSettings assumes created component because multiple invoke
readSettings have to have the same effect, it doesn't differ if
component is created or isn't created,
readSettings precedes writeSettings etc.

Requirement: replace WD.getComponet with createComponent which can by
called only once (name "getComponent" is confusing because is called
several times and shouldn't create new component each time).
Comment 3 Milos Kleint 2003-02-15 10:01:51 UTC
Copy & pasting from openide-dev discussion.

The current state is IMHO reflects the history and evolution of the
API quite well, but it's not very usable. I imagine we've had just
NotifyDescriptors in at the beginning, for showing messages. then
someone came up with the idea that a dialog is actually just a custom
message and came up with DialogDescriptor, later taht was extended,
because Wizards are just a sequence of dialogs, right? TemplateWizard
is a natural last step so far.
So all these form one nice inheritance tree, however the problem is
that you can call safely only the wizarddescriptor's methods when
dealing with wizard and should not try to call anything that smells
like a method from NotifyDescriptor or dialogdescriptor, because these
would break the whole thing. So why have them extend it after all? 
Comment 4 Jiri Rechtacek 2003-08-26 17:41:45 UTC
It's a umbrella issue, not direct ask of projects team => removed
'projects' flag.
Comment 5 Jiri Rechtacek 2003-08-26 17:42:18 UTC
It's a umbrella issue, not direct ask of projects team => removed
'projects' flag.
Comment 6 Jiri Rechtacek 2003-10-21 09:00:50 UTC
Replace relation depends on to blocks, i.e. the this umbrella issue
will depend on enhancements and task against wizard and these issues
won't depend on this issue.
Comment 7 Jiri Rechtacek 2003-10-21 09:01:40 UTC
Replace relation depends on to blocks, i.e. the this umbrella issue
will depend on enhancements and task against wizard and these issues
won't depend on this issue.
Comment 8 Jiri Rechtacek 2008-10-16 15:00:23 UTC
Not planned for ever


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo