Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 35759 - Offer to cancel running actions at system shutdown time
Offer to cancel running actions at system shutdown time
Status: VERIFIED DUPLICATE of bug 39640
Product: platform
Classification: Unclassified
Component: Execution
3.x
All All
: P3 (vote)
: 4.x
Assigned To: Jesse Glick
issues@platform
:
Depends on: 27403
Blocks: 35755
  Show dependency treegraph
 
Reported: 2003-08-25 22:56 UTC by Jesse Glick
Modified: 2008-12-22 20:53 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2003-08-25 22:56:08 UTC
Functionality broken by lack of global registry of
running actions in ModuleActions (communicated to
o.n.c.execution.Install). Needs to be done some
other way, probably requiring a new API - old way
was just a core-private hack (similar for saving
settings etc.).
Comment 1 Jesse Glick 2004-01-28 16:20:29 UTC
Suggest to leave this till promo-D since it really seems to require
some kind of progress API, and none exists yet. The most typical
long-running actions (compilation, execution) anyway use
ExecutionEngine which assures that the shutdown dialog will display
them. The remaining cases are not as likely I think: e.g. copying an
enormous folder from one place to another (why you would do this in
the IDE to begin with I am not sure). Perhaps VCS actions - no idea
how these work. Note that a module can always use
ModuleInstall.closing to veto IDE shutdown if it is doing something
critical; this is about it being *automatic* just by virtue of an
action not having completed.
Comment 2 Jesse Glick 2004-02-17 16:31:22 UTC
Handled for 3.6 in issue #39640. Better solution desired for D but
that is already covered pretty well by issue #27403.

*** This issue has been marked as a duplicate of 39640 ***
Comment 3 Marian Mirilovic 2004-03-19 13:24:11 UTC
verified duplicate


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo