Bug 35755 - Move actions to the event thread
Move actions to the event thread
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Actions
3.x
All All
: P3 (vote)
: 3.x
Assigned To: Jesse Glick
issues@platform
: API, THREAD
Depends on: 35759
Blocks: 35753
  Show dependency treegraph
 
Reported: 2003-08-25 18:15 UTC by Jesse Glick
Modified: 2008-12-22 20:52 UTC (History)
2 users (show)

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2003-08-25 18:15:08 UTC
Patch should make the normal behavior for actions
to be run directly in the event thread as called.
For compatibility, old actions will still use the
RP, with a runtime warning.
ActionManager.invokeAction will not be needed,
since the threading will be handled by the action,
not the invoker.

Patch in progress, watch for CVS info etc.
Comment 1 Jesse Glick 2003-08-25 22:53:58 UTC
committed 1.3  
apisupport/lite/src/org/netbeans/modules/apisupport/lite/resources/actions-__Sample_callable__Action_java
committed 1.4  
apisupport/src/org/netbeans/modules/apisupport/resources/templates/Actions_API/__Sample_cookie__Action_java
committed 1.5  
apisupport/src/org/netbeans/modules/apisupport/resources/templates/Actions_API/__Sample_node__Action_java
committed 1.7  
apisupport/src/org/netbeans/modules/apisupport/resources/templates/Window_System_API/TemplateWizardIterator_java
committed 1.26  core/manifest.mf
committed 1.12  core/execution/manifest.mf
committed 1.10 
core/execution/src/org/netbeans/core/execution/Install.java
committed 1.29  core/src/org/netbeans/core/ModuleActions.java
committed 1.8  
core/src/org/netbeans/core/actions/NewTemplateCallableAction.java
committed 1.25  core/src/org/netbeans/core/actions/SystemExit.java
removed   1.4   core/src/org/netbeans/core/ui/MouseCursorUtils.java
committed 1.101 core/www/plans/plan.xml
committed 1.19 
java/src/org/netbeans/modules/java/ui/wizard/JavaWizardIterator.java
committed 1.119 openide/openide-spec-vers.properties
committed 1.165 openide/api/doc/changes/apichanges.xml
committed 1.22  openide/api/doc/org/openide/doc-files/threading.html
committed 1.63  openide/api/doc/org/openide/doc-files/upgrade.html
committed 1.3  
openide/loaders/src/org/openide/loaders/TemplateWizard.java
committed 1.8   openide/src/org/openide/actions/ActionManager.java
committed 1.49  openide/src/org/openide/actions/PasteAction.java
committed 1.86  openide/src/org/openide/awt/Actions.java
committed 1.66  openide/src/org/openide/explorer/view/ListView.java
committed 1.52  openide/src/org/openide/explorer/view/MenuView.java
committed 1.49  openide/src/org/openide/explorer/view/TreeTableView.java
committed 1.136 openide/src/org/openide/explorer/view/TreeView.java
committed 1.14 
openide/src/org/openide/util/actions/CallableSystemAction.java
committed 1.35 
openide/src/org/openide/util/actions/CallbackSystemAction.java
added     1.1   openide/src/org/openide/util/actions/MouseCursorUtils.java
committed 1.41  openide/src/org/openide/util/actions/NodeAction.java
committed 1.70  openide/src/org/openide/util/actions/SystemAction.java
committed 1.103 openide/src/org/openide/windows/TopComponent.java
committed 1.4  
openide/test/unit/src/org/openide/actions/MoveUpActionTest.java
committed 1.9  
openide/test/unit/src/org/openide/util/actions/ActionsInfraHid.java
committed 1.4  
openide/test/unit/src/org/openide/util/actions/BooleanStateActionTest.java
committed 1.8  
openide/test/unit/src/org/openide/util/actions/CallbackSystemActionTest.java
committed 1.8  
openide/test/unit/src/org/openide/util/actions/CookieActionTest.java
committed 1.10 
openide/test/unit/src/org/openide/util/actions/NodeActionTest.java
Comment 2 Jesse Glick 2003-08-25 23:33:37 UTC
Also
java/src/org/netbeans/modules/java/ui/wizard/JavaWizardIterator.java
v. 1.12.14.12 (merge to prj40_prototype).
Comment 3 Jesse Glick 2003-09-06 17:13:25 UTC
Also trying to put misc. Action property changes in EQ:

committed   * Up-To-Date  1.12       
core/output/src/org/netbeans/core/output/OutputTabTerm.java
committed   * Up-To-Date  1.23       
core/src/org/netbeans/core/NbKeymap.java
committed   * Up-To-Date  1.42       
debuggercore/src/org/netbeans/modules/debugger/multisession/EnterpriseDebugger.java
committed   * Up-To-Date  1.19       
debuggercore/src/org/netbeans/modules/debugger/support/actions/CreateVariableAction.java
committed   * Up-To-Date  1.167      
openide/api/doc/changes/apichanges.xml
committed   * Up-To-Date  1.4        
openide/loaders/src/org/openide/actions/SaveAllAction.java
committed   * Up-To-Date  1.87       
openide/src/org/openide/awt/Actions.java
Comment 4 Tomas Hurka 2004-01-19 15:08:48 UTC
*** Issue 37090 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo