Bug 35701 - Window system actions periodically disabled
Window system actions periodically disabled
Status: VERIFIED DUPLICATE of bug 35499
Product: platform
Classification: Unclassified
Component: Window System
3.x
PC Linux
: P2 (vote)
: 3.x
Assigned To: Peter Zavadsky
issues@platform
: FOCUS, RANDOM, REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-21 14:32 UTC by Jesse Glick
Modified: 2008-12-23 09:46 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Screenshot - note that an editor tab is selected and focussed, yet all 3 actions are incorrectly disabled (87.01 KB, image/png)
2003-08-21 14:34 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2003-08-21 14:32:08 UTC
[dev aug 19] This is a regression, introduced I
think sometimes in the past week or so. I can see
it also in [dev aug 11] but I don't remember it
occurring in any previous dev builds. I am using
Linux with the Sawfish WM, NB in MDI mode.

When there are several tabs open in a mode, e.g.
editor, sometimes actions such as Next View
(Alt-Right) or Alt-Left or Ctrl-F4 are enabled,
and sometimes they are not. I can't establish any
exact pattern, but pressing Ctrl-Z or Ctrl-S or
some other kinds of keys (but not self-insert
typed keys, and not usually Backspace) in a
text/x-java buffer (but not text/plain?) seems to
trigger it. Suddenly the window system actions are
disabled (but e.g. Ctrl-S is not).

I created a toolbar, for testing purposes, with
FindAction, NextTabAction, and PreviousTabAction.
Of course if you are moving around in the editor
with >1 tab, they should all always be enabled.
But they aren't. Sometimes none of them are;
sometimes only Find is; sometimes only Next and
Previous are.

Find seems to be usually on, but sometimes when
switching Sawfish desktops back to NB it is not.
Switching to another tab and then back turns it on.

Next and Previous are always on after having
switched focus back to the NB main window, e.g.
after switching desktops. If all you do is scroll
up or down or otherwise move the cursor, and/or
switch tabs (Alt-Left and Alt-Right), they stay
on. But if you start working in a buffer - typing
something in it - they usually turn off. At that
point Alt-Left etc. just beep, as does Ctrl-F4.
You cannot switch buffers except with the mouse.
(If you do click on a new editor tab, the actions
turn on again.)

Best KB-accessible workaround seems to switch
virtual desktops away and back to NB, or to switch
focus to some other app and back to NB.

Marking P2 because this bug is extremely annoying
and interferes with everyday work. Also a recent
regression.
Comment 1 Jesse Glick 2003-08-21 14:34:21 UTC
Created attachment 11390 [details]
Screenshot - note that an editor tab is selected and focussed, yet all 3 actions are incorrectly disabled
Comment 2 Jesse Glick 2003-08-21 14:43:03 UTC
Note: possible duplicate of #35499, I am not sure.
Comment 3 Jaroslav Tulach 2003-08-22 12:45:55 UTC
Let's pretend this is a duplicate of 35499. There was a problem with
CallbackSystemActions which is fixed now and as window system actions
are CallbackSystemActions, I believe it is safe to hope that this is
fixed as well.

*** This issue has been marked as a duplicate of 35499 ***
Comment 4 Marian Mirilovic 2003-09-03 17:10:17 UTC
verifying duplication
Comment 5 Jan Chalupa 2003-11-03 15:34:55 UTC

*** This issue has been marked as a duplicate of 35499 ***
Comment 6 Jan Chalupa 2003-11-03 15:36:10 UTC
... verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo