Bug 35273 - Deadlock in InheritanceSupport
Deadlock in InheritanceSupport
Status: RESOLVED WONTFIX
Product: java
Classification: Unclassified
Component: Unsupported
3.x
Sun Solaris
: P2 (vote)
: 3.x
Assigned To: issues@java
issues@java
: RANDOM, THREAD
: 35544 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-05 09:55 UTC by Petr Nejedly
Modified: 2007-09-26 09:14 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
The deadlock stack traces (5.20 KB, text/plain)
2003-08-05 09:56 UTC, Petr Nejedly
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Nejedly 2003-08-05 09:55:31 UTC
I'll attach the deadlock trace
Comment 1 Petr Nejedly 2003-08-05 09:56:07 UTC
Created attachment 11212 [details]
The deadlock stack traces
Comment 2 Petr Nejedly 2003-08-05 09:57:21 UTC
Actually, it happened to me in 3.5.1, but we have no such version
entry...
Comment 3 Tomas Hurka 2003-08-05 14:15:12 UTC
Please, provide steps how to reproduce it. Thanks.
Comment 4 Petr Nejedly 2003-08-05 14:28:29 UTC
I hope it doesn't matter, you see two threads running in paralel
and acquiring locks in different order, which is always wrong and
always potential deadlock.

IIRC, I've only invoked popup->new->JFrame when I was already
on (so far empty) gui editing workspace. I cannot recall
whether I've already filled in the form name and pressed finish..
Comment 5 Tomas Hurka 2003-08-05 14:44:52 UTC
It does matter. Steps can be used to verify the fix and also to set the priority of the 
issue. In this case I am lowering priority to P2. 
Comment 6 Jan Pokorsky 2003-11-11 15:25:39 UTC
*** Issue 35544 has been marked as a duplicate of this issue. ***
Comment 7 Jan Pokorsky 2003-12-01 18:10:01 UTC
The affected code has been refactored and simplified. Namely
InheritanceSupport (now InheritanceSupport2) and JavaWizard.

Closed as WONTFIX.
Comment 8 Quality Engineering 2007-09-20 11:51:50 UTC
Reorganization of java component


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo