Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 34154 - Background color of a non editable property value in the PS
Background color of a non editable property value in the PS
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Explorer
3.x
PC All
: P3 (vote)
: 3.x
Assigned To: _ tboudreau
issues@platform
http://ui.netbeans.org/docs/ui/proper...
:
Depends on:
Blocks: 33815
  Show dependency treegraph
 
Reported: 2003-06-04 15:52 UTC by dpavlica
Modified: 2008-12-22 17:45 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Different background of non editable property and editable one. (7.25 KB, image/png)
2003-06-04 15:54 UTC, dpavlica
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dpavlica 2003-06-04 15:52:32 UTC
Background color of non editable property in the Property 
Sheet should have the same color as editable property.
It's different in the current version (see next appendix 
please).
Comment 1 dpavlica 2003-06-04 15:54:23 UTC
Created attachment 10586 [details]
Different background of non editable property and editable one.
Comment 2 _ tboudreau 2003-06-04 17:38:58 UTC
That's because light gray text on a light blue background is 
unreadable.  It is by design.  The alternative is to make the
color black only when it's selected, but then you cannot tell
that a property is non editable when it is selected.
Comment 3 Lukas Hasik 2004-01-13 17:01:42 UTC
have to reopen -> the implementation have to follow the ui spec.
reopening as defect, TM=3.6
Comment 4 _ tboudreau 2004-01-13 20:50:27 UTC
Yes, this is on my to-do list for 3.6.  The plan was to do this after
integrating the HTML support (since in a normal JLabel, you cannot
control what color is used for disabled text).  Since HTML integration
is postponed, we'll do it another way now - but it's a pity to have to
do the same work twice.
Comment 5 _ tboudreau 2004-01-21 07:25:52 UTC
Fixed on my laptop, will commit later today.
Comment 6 _ tboudreau 2004-01-21 21:11:05 UTC
Fixed in trunk.
Comment 7 Lukas Hasik 2004-03-15 15:57:17 UTC
verified 


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo