Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 33815 - Property Sheet UI issues
Property Sheet UI issues
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Explorer
3.x
PC Windows ME/2000
: P3 (vote)
: TBD
Assigned To: _ tboudreau
issues@platform
:
Depends on: 33981 33982 33983 33984 33985 34151 34154 34158 34159 34164 34554 34555
Blocks: 29447
  Show dependency treegraph
 
Reported: 2003-05-21 23:46 UTC by dpavlica
Modified: 2008-12-23 11:37 UTC (History)
2 users (show)

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dpavlica 2003-05-21 23:46:10 UTC
There are a list of visual issues by PS, which should be 
fixed:

Left gray column ends in the middle of Property Sheet Area 
sometimes, but it should be displayed across all height of 
Property Sheet. It means form the top of PS to a bottom, 
where Description Area starts.

Description area should be resizable by mouse dragging. It 
means then splitter between PS area and Description Area 
will exist.

Text in the Property cells are too close to the left gray 
column without any space. Texts at the category and 
property rows should start at the same position from left 
side. The same width of space should exist between table's 
border and texts of property values.

Three dots inside a Customizer button are moved to the 
right side of the button. It should be aligned to the 
center.

Context menu has Menu Item Sort By Importance. It should 
be changed to Sort By Category. 

Menu Item for showing Read only properties is missing too 
in the Context menu.

Properties in the Events category have a strange behavior. 
First I sow value <none> but empty Combo with violet 
background appeared after a click.

Background of disabled cells is different then for Enabled 
cells. I think that it should be the same as it works in a 
JTable. It means the same color.
Comment 1 _ tboudreau 2003-05-22 01:39:12 UTC
The following are already fixed (see the tasks referring
to them marked as completed - try Show dependency tree above):

- Left gray column is full height
- Property name text alignment
- Sort by importance -> category

Background of disabled cells is different color - can't reproduce

Show read only properties item - I thought we agreed a 
long time ago to eliminate it - it complicates the UI and
offers almost no value;  if modules are exposing useless
information, bugs should be filed against those modules.
Note also that it is not uncommon to have a "read-only"
property that does provide a custom editor, but should
look read-only in the property sheet.  Editor settings |
Fonts and Colors is an example.

Properties in the events category are editable combo
boxes - they have the recommended behavior of 
selecting the full text they contain when first opened,
to make it easier for the user to replace it - same
behavior as a text property.

Comment 2 _ tboudreau 2003-05-22 01:45:33 UTC
FYI, I've created the following individual tasks 
representing uncompleted items in this list:

 - issue 33817 - center the ... in the customize button
 - issue 33818 - (maybe) implement the "show editable only"
menu item
Comment 3 _ tboudreau 2003-05-25 00:56:16 UTC
Closing this issue since there are now individual tasks
for the various bits of work described here.
Comment 4 dpavlica 2003-05-26 09:56:55 UTC
Great progress, thanks!
I checked the newest version and I found next issues:

Texts (or components) in the second column (property values) aren't
aligned and should start at the same position from a left side (it
means from a table's border). This inconsistency is visible by text in
Combo Box or by Check Box for example.

There is a problem with a text in non editable rows. Right non
editable text should be gray, but in the Form editor it's black
sometimes (e.g. PropertychangeListeners value or TopLevelAncestors value).
And left text color could be black maybe?...because it's name of
property (it means label, not value).

When Description Area obtains focus, then text inside is changed. It
seems confusing a bit.

Only white screen appears instead <No properties> text sometimes. This
is visible after invocation of Option window.

There is incorrect capitalization in a Context Menu of the PS. Please
change it to following texts:
Sort by Category
Show Description Area
Comment 5 David Simonek 2003-05-26 14:45:27 UTC
Dusan, please create individual issues for each thing you've found. It
is *very messy* to have 5 issues merged into one. We (as a core
development team) have the *strong strategy* to file separate issues
for separate problems.
Please, do us a favour:
- file separate issues
- make them all block this one (which means this one will be treated
like umbrella issue).
Thanks for your understanding.
Comment 6 _ tboudreau 2003-06-25 18:43:30 UTC
Closing this issue so issue 33818 doesn't show up twice
in the dependency list - makes tracking the issues 
confusing.  All others related to this are closed.
Comment 7 _ tboudreau 2003-06-25 18:44:58 UTC
Closed.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo